Highlighted

Higher CPU load on selection in Organizer

Explorer ,
May 31, 2020

Copy link to clipboard

Copied

Hello,

 

sometimes, not always, Elements Organizer is in a strange mode: In Media Grid View, the CPU load goes up to around 30% caused by "Adobe Elements 2020 Organizer" when having a photo selected (just selected, nothing else). The CPU load can be modulated, lowering down to around 5% with deselecting the image andincreasing to the mentioned 30% by selecting any image.

 

Closing and restarting Organiser helps, selecting any image (also the same images as before) does not lead to an increase in CPU load. I don't know what it is that causes Organizer to enter this mode.

 

Under Preferencens, Media Analysis everything apart from Auto Creations is turned on, but I haven't imported photos now for a while so all analysis should be done, which corresponds also to the fact that no ongoing operations are mentioned in the status bar.

 

I let it run all night long with the high CPU usage, no difference at all.

 

Do you have any idea what could cause this and how to get rid of it?

 

Many thanks in advance!

TOPICS
Bug, Organizer, Performance, Problem or error, Windows

Views

465

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Higher CPU load on selection in Organizer

Explorer ,
May 31, 2020

Copy link to clipboard

Copied

Hello,

 

sometimes, not always, Elements Organizer is in a strange mode: In Media Grid View, the CPU load goes up to around 30% caused by "Adobe Elements 2020 Organizer" when having a photo selected (just selected, nothing else). The CPU load can be modulated, lowering down to around 5% with deselecting the image andincreasing to the mentioned 30% by selecting any image.

 

Closing and restarting Organiser helps, selecting any image (also the same images as before) does not lead to an increase in CPU load. I don't know what it is that causes Organizer to enter this mode.

 

Under Preferencens, Media Analysis everything apart from Auto Creations is turned on, but I haven't imported photos now for a while so all analysis should be done, which corresponds also to the fact that no ongoing operations are mentioned in the status bar.

 

I let it run all night long with the high CPU usage, no difference at all.

 

Do you have any idea what could cause this and how to get rid of it?

 

Many thanks in advance!

TOPICS
Bug, Organizer, Performance, Problem or error, Windows

Views

466

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 31, 2020 0
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

30% ?

Nothing to worry about. That's absolutely normal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2020 0
Explorer ,
May 31, 2020

Copy link to clipboard

Copied

Thanks for your immediate reply!

 

As it makes the fan of the laptop noisy and I am not sure whether it is really needed, I would like to know the reason behind it and how to avoid it, in case it should really not be nessary?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2020 0
Engaged ,
Jun 01, 2020

Copy link to clipboard

Copied

That's odd! My PC runs between 0 and 2% when the Organizer is running. I have ALL Media-Analysis enabled except for videos. I have an Intel i9-9900K CPU with 32 GB of memory.

2020-06-01 10_04_35-Task Manager.png

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Explorer ,
Jun 01, 2020

Copy link to clipboard

Copied

Yeah, I find it very strange, too. It just happened again and I also made a screenshot showing how I can modulate the CPU load as described:

 

Neb1_0-1591021315664.png

During the times with higher CPU load, all other open programs are as responsive to use as usual, just Elements is very slow: Searching for missing files, as an example, usually takes less than 1s and lasts for like 30s during high CPU loads caused by a selected image in Elements. Of course, when image selection does not cause high CPU load, the time of searching for missing files is independent whether an image is selected or not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Engaged ,
Jun 01, 2020

Copy link to clipboard

Copied

My memory usage does not act like that - at least on my desktop which I use just about all of the time. Sometimes it will spike up to about 25% and drop right down when I select a photo, but just sometimes. It must be the way the CPU operates. I noticed that mine has something called "Hyper-V support" enabled which yours does not.

2020-06-01 10_59_22-Task Manager.png

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Engaged ,
Jun 01, 2020

Copy link to clipboard

Copied

This is a graph from my laptop while running the Organizer. I had just selected 7 photos and it peaked similar to what you see for each one about 10-15 seconds apart. All the peaks were not that high.

Annotation 2020-06-01 111703.jpg

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Walter_H LATEST
Engaged ,
Jun 01, 2020

Copy link to clipboard

Copied

I'm just curious. Are you using the GPU that's integrated into your CPU?

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0
Engaged ,
Jun 01, 2020

Copy link to clipboard

Copied

FYI, the above pic shows the memory usage on my desktop PC. I just checked my laptop PC and it also runs between 0 and 2% when the Organizer is running. My laptop has an Intel 17-7700HQ CPU with 32 GB of memory.

Annotation 2020-06-01 104135.jpg

 

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2020 0