Highlighted

How to make Phtoshop Elements 11 work on Mac Os Catelina version 10.15

New Here ,
Oct 08, 2019

Copy link to clipboard

Copied

Hi, I just updated to Mac OS Catelina version 10.15. Then my phptoshop elements 11 can't use on it. Do you know if this photoshop elements 11 can be used somehow? Or do i need to buy newer photoshop? Can the new one work? If someone can help me, it'd be great! Thank you!

 

Views

140

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to make Phtoshop Elements 11 work on Mac Os Catelina version 10.15

New Here ,
Oct 08, 2019

Copy link to clipboard

Copied

Hi, I just updated to Mac OS Catelina version 10.15. Then my phptoshop elements 11 can't use on it. Do you know if this photoshop elements 11 can be used somehow? Or do i need to buy newer photoshop? Can the new one work? If someone can help me, it'd be great! Thank you!

 

Views

141

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 08, 2019 0
Most Valuable Participant ,
Oct 08, 2019

Copy link to clipboard

Copied

There's no chance to update old apps. Apple have decided we all need to be running the very latest software and forever blocked the old stuff. Frankly, it's too early to talk about Photoshop Elements, Adobe will surely release a new version in due course. It's strongly recommended to check the compatibility of every single app you own and every plug-in/filter before any new mac OS, and never never upgrade in the first month. This is called the "bleeding edge" by those who have been there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0
New Here ,
Oct 15, 2019

Copy link to clipboard

Copied

Thank you very much for your reply. Whatever happened, it's an experience, isn't it? I know what to do next time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0
Adobe Community Professional ,
Oct 08, 2019

Copy link to clipboard

Copied

macOS Catalina won't run 32 bit applications, which is what photoshop elements 11 is, so unfortunately upgrading to photoshop elements 2020 is the only way to have a fully compatible photoshop elements with macOS Catalina.

 

https://support.apple.com/en-us/HT208436

 

The new photoshop elements 2020 is a 64 bit application that adobe says will work on macOS Catalina.

 

https://community.adobe.com/t5/Photoshop-Elements/The-future-is-here-Introducing-Adobe-Photoshop-Ele...

 

https://helpx.adobe.com/photoshop-elements/system-requirements.html

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0
New Here ,
Oct 15, 2019

Copy link to clipboard

Copied

Thank you very much for your reply. OK. I will have a look into it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0