Highlighted

I can't get the the map view to work in "Places" in PSE 2019

New Here ,
Dec 13, 2018

Copy link to clipboard

Copied

Hi,

I recently upgraded to PSE 2019, but I still can't get the "Places" map to work or show any of my photos by location, neither in "Pinned" or "UnPinned" view. I used to have PSE14, and the "Places" worked fine there, for a while, until they didn't anymore. I have been searching the Forums to see if anyone else has the same problem, but all I can find is information saying the "Places" function doesn't work anymore with versions PSE18 and older, and recommendations to upgrade to 2019 as there is a new Map service provided there: Well I've upgraded, but still can't get it to work! I'm using Windows 10 Home - 2018. Any help or suggestions would be greatly appreciated. 🙂

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

I can't get the the map view to work in "Places" in PSE 2019

New Here ,
Dec 13, 2018

Copy link to clipboard

Copied

Hi,

I recently upgraded to PSE 2019, but I still can't get the "Places" map to work or show any of my photos by location, neither in "Pinned" or "UnPinned" view. I used to have PSE14, and the "Places" worked fine there, for a while, until they didn't anymore. I have been searching the Forums to see if anyone else has the same problem, but all I can find is information saying the "Places" function doesn't work anymore with versions PSE18 and older, and recommendations to upgrade to 2019 as there is a new Map service provided there: Well I've upgraded, but still can't get it to work! I'm using Windows 10 Home - 2018. Any help or suggestions would be greatly appreciated. 🙂

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 13, 2018 0
Participant ,
Dec 13, 2018

Copy link to clipboard

Copied

Hi,

Could you please check, if media filter is not applied.

Goto View -> media type and make sure all the options are checked.

Also could you please confirm, if your machine is connected to internet and map is loading fine.

Thanks

Prakash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2018 0
New Here ,
Dec 14, 2018

Copy link to clipboard

Copied

Hi,

Yes, I have checked and unchecked the boxes for "Media Types" from the View tab when in "Media" view. When in the "Places" view the "Media Types" are not active from the "View" tab, they are grey and inactive. The map doesn't load, just a black space in both "Pinned" and "UnPinned". When I close the program when in the "Places" view, I do see that a world map appears for a few seconds with a message "A network connection is required to access the map", and then the program closes. My internet connection is working fine for everything else, I have checked it. Any ideas?

Regards

Shane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2018 0
Participant ,
Dec 16, 2018

Copy link to clipboard

Copied

Hi,

Could you please go to Edit -> Preferences -> Country/Region Selection and check which country is selected.

Please change it to US or your local Region, kill the app and launch again.

Please let us know if this helps.

Thanks

Prakash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2018 0
New Here ,
Dec 17, 2018

Copy link to clipboard

Copied

Hi,

I have changed the Country/Region from Norway to US and relaunched, but the map still doesn't load. 😞

Regards

Shane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2018 0
New Here ,
Apr 08, 2019

Copy link to clipboard

Copied

I have had the same problem for a few months now. It seems to work fine when I am using the PC on WiFi and not through my docking station. As soon as I plug in through the dock, the places will not load.

UPDATE - I had other monitors hooked up through a docking station. The other monitor was listed as my "main display". I changed the "main display" to the laptop, instead of the additional monitor and it worked! So when I want to work in PSE, I change the main display settings. The Pluggable Support are the ones that helped me figure it out. Below is the thread from their support team. They explained it alot better than I can.

https://support.plugable.com/t/photoshop-elements-19-pse-places-will-not-load/16845

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2019 2
New Here ,
Dec 20, 2019

Copy link to clipboard

Copied

Thank you for posting this.  I have not been able to add locations since March this year, searched all the forums and asked support several times with no results.   The removing laptop from docking station solved the issue for me as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2019 0
New Here ,
Jun 05, 2020

Copy link to clipboard

Copied

This fixed Places not showing for me with PSE 2019. I was working through a dock, changed main monitor to laptop, and then Places map reappeared. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
New Here ,
Dec 24, 2018

Copy link to clipboard

Copied

Hi,

I am having the exact same problem.  Just bought the PSE 2019 less than 1 month ago and the map was working up to 2-3 days ago.

I have tried the region change suggested from US to Singapore and from Singapore back to US but this doesn't seem to help.  The map still does not load and when closing the Organizer while in Places I will see the following screen flash for a couple of seconds:

PSE Error.PNG

My PC is running Windows 10 and I have tried turning off the Firewall totally.  I am writing this using the same PC so have no Internet access issues on the PC.

Regards

LingSK

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2018 0
Community Beginner ,
Jan 10, 2019

Copy link to clipboard

Copied

I have PSE-16(2018).

I'd not used the map view for several months, but having just added and place-tagged several hundred new photos, I decided to take a look.  No map!  Got a notification that Google Maps 'had changed', was sent to this Adobe web page, where the bottom line workaround is said: If you would like to continue to use the Map view feature, upgrade to Photoshop Elements 2019

Naive me, I was expecting to be sent to a page explaining how existing users with that feature could upgrade.  No, clicking on that link takes me to the buy-it page.  As far as I can tell, Adobe claims that Places works in 2019, but wants users to pay for the upgrade to get back a feature that we have ALREADY PAID FOR.

If they really fixed it in 2019, then why can't they apply the fix to prior versions which are now broken?  This is not a 'minor bug', and it does not have a 'workaround' within the software - it is a major functionality of the software for which users have already paid.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 4
New Here ,
Aug 02, 2019

Copy link to clipboard

Copied

I'm in the same situation..  I purchased Photoshop Elements 2018 - a key reason for buying Photoshop Elements 2018 was the Map View function.

A few months later Adobe advised that Map View would no longer be available in Elements 2018:

https://helpx.adobe.com/elements-organizer/kb/maps-not-loading.html

I was not happy to be told I had to pay for the new version of Elements 2019!!!

My question is... How do I request a free upgrade to Elements 2019 so that I can use Map View again?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2019 0
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

Purchased PSE 2019 today as recommended when the map function no longer worked in PSE 2018.  I noted the same problem with no map display.  I tried the tips suggested by Kumar with no improvement noted.  Place tags are displayed on the right side of the media space as expected.  Under places unpinned photos are recognized and displayed as expected  Pinned photos are not displayed or mapped.  Additionally, I verified that GPS data was present in the file properties detail.

     An update from a few minutes later ….

Maps displayed with pinned photos present. I closed the program then started it again and was back to the original problem.  Could there a large amount of data that has to load before the maps will display?  I have pinned photos from the far east across the Pacific, US and as far as the eastern Med.

     An update from the next day ….

Uninstalling PSE 2018 did not improve matters, still no maps.  I additionally noted that when following the location preference troubleshooting tip from Kumar a message box said services were updated and a second box that said updating online service list that included a moving activity bar.  This second box has me wondering if something really did not update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Adobe Employee ,
Apr 25, 2019

Copy link to clipboard

Copied

Hi,

Can you please share your graphics card details?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2019 0
New Here ,
May 21, 2019

Copy link to clipboard

Copied

I have two graphic card on my Dell laptop, Nvidia 750M and Intel 4600.  Thank you for the follow-up.  I came back to this topic with a possible solution.  I share my Windows 10 system with one other user that has access to PSE 2019.  This user account is rarely used and had never used PSE 2019.  Today I logged into that account to exercise the apps and complete updates if any.  I started PSE 2019 and it wanted to convert the Catalog.  That process failed but the Organizer media eventually appeared.  I closed the app and ended the user session.  I then started PSE 2019 in my own session and opened PSE 2019 Organizer media as usual.  I then selected an album then switched to Places.  This time the Mapbox map finally appeared.   I don't know why, could just be coincidence, but I will take it.

A few minutes later...

Now that Mapbox maps are working I see I have to manage how I use my external monitor.  Mapbox will not appear in PSE 2019 if I start the app with the external monitor powered.  If I start the app on my laptop display , select Places, then power the external monitor, all is well.  This is the same process I have used with some games that don't care for dual displays.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2019 0