Highlighted

I have PSE 2019 and working on an iMac with macOS Catalina.

New Here ,
Mar 29, 2020

Copy link to clipboard

Copied

Since upgrading to the mac OS, PSE 2019 no longer seems to work.  Is there a plug-in to allow it work with macOS Catalina (ver 10.15.2)?

TOPICS
Mac, Performance, Problem or error

Views

99

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

I have PSE 2019 and working on an iMac with macOS Catalina.

New Here ,
Mar 29, 2020

Copy link to clipboard

Copied

Since upgrading to the mac OS, PSE 2019 no longer seems to work.  Is there a plug-in to allow it work with macOS Catalina (ver 10.15.2)?

TOPICS
Mac, Performance, Problem or error

Views

100

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 29, 2020 0
Phinny LATEST
Enthusiast ,
Mar 29, 2020

Copy link to clipboard

Copied

Catalina doesn't support 32 bit apps.  You'll need to roll your OS back to Mojave or purchase PSE 2020.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2020 0