Highlighted

Icon size is sooooo small.

New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

I have a 5K and 8K monitor and the fonts and icons are so small I almost need a magnifying glass to see them.  I've gone into the preferences and raised the fonts to their max. but they're still way too small.  I have Capture One and the icon sizes are a normal size.  Any ideas?  I know this is an issue and I'm baffled why Adobe can't fix this when one of their competitors have it right.

Thanks in advance.

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Try the following and hopefully the results will be better:

1. In the pse 14 editor go to Edit>Preferences>Display & Cursors and set the UI Scale Factor to Small-100%

    Then quit the pse 14 editor.

2. Go to C:\Program Files\Adobe\Photoshop Elements 14, right click on the PhotoshopElementsEditor.exe

     click on Properties>Compatibility>Change high DPI Settings>Override high DPI scaling behavior>System Enhanced.

Screenshot-(115).png

Views

3.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Icon size is sooooo small.

New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

I have a 5K and 8K monitor and the fonts and icons are so small I almost need a magnifying glass to see them.  I've gone into the preferences and raised the fonts to their max. but they're still way too small.  I have Capture One and the icon sizes are a normal size.  Any ideas?  I know this is an issue and I'm baffled why Adobe can't fix this when one of their competitors have it right.

Thanks in advance.

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Try the following and hopefully the results will be better:

1. In the pse 14 editor go to Edit>Preferences>Display & Cursors and set the UI Scale Factor to Small-100%

    Then quit the pse 14 editor.

2. Go to C:\Program Files\Adobe\Photoshop Elements 14, right click on the PhotoshopElementsEditor.exe

     click on Properties>Compatibility>Change high DPI Settings>Override high DPI scaling behavior>System Enhanced.

Screenshot-(115).png

Views

3.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

What adobe application and operating system are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

Elements 14.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

What operating system are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

Elements 14.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Most Valuable Participant ,
Feb 18, 2019

Copy link to clipboard

Copied

An operating system is something like "Mac OS 10.8" or "Windows 8.1". What operating system are you using with your high resolution monitor and Elements 14?


Why do you say Adobe haven't fixed this when you haven't upgraded to the latest version?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

I'm using Windows 10. Are you saying that the latest Elements has

addressed this issue?

On Mon, Feb 18, 2019 at 7:56 PM Test Screen Name <forums_noreply@adobe.com>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

In the pse 14 editor go to Edit>Preferences>Display & Cursors, set the UI Scale Factor to Large-200% and restart the pse 14 editor.

uis.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

Thanks for the info. but I've done that and you can see from my attachment

it really hasn't done anything. Still almost impossible to see.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

Do you have both monitors hooked up?

What happens if you just have the 5K monitor hooked up?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 18, 2019

Copy link to clipboard

Copied

The 5K is a little better but the 8K is what I used in my attachment in my

last reply. As I mentioned, I have Capture One and it's icons and text are

at a normal size as I hope you can see in the attachment with the 8K

monitor. I just wonder why Adobe can't do that with Photoshop?

On Mon, Feb 18, 2019 at 11:11 PM Jeff Arola <forums_noreply@adobe.com>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

Unfortunately, the adobe forums don't accept email attachments.

You have to use the Insert Image button in the forum itself.

ar.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
Adobe Community Professional ,
Feb 18, 2019

Copy link to clipboard

Copied

Try the following and hopefully the results will be better:

1. In the pse 14 editor go to Edit>Preferences>Display & Cursors and set the UI Scale Factor to Small-100%

    Then quit the pse 14 editor.

2. Go to C:\Program Files\Adobe\Photoshop Elements 14, right click on the PhotoshopElementsEditor.exe

     click on Properties>Compatibility>Change high DPI Settings>Override high DPI scaling behavior>System Enhanced.

Screenshot-(115).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2019 0
New Here ,
Feb 19, 2019

Copy link to clipboard

Copied

Thanks Jeff. That did the trick. I'm guessing that there are a lot of

people out there with 4K and up monitors with the same problem so it would

be nice for Adobe to have this as an option or at least explain how to do

it in their programs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2019 0
New Here ,
Dec 24, 2019

Copy link to clipboard

Copied

Your fix beginning with Paragraph 2 (going to the program and right-clicking on the "exe" file, etc) finally fixed the same problem I have in Photoshop CS5.1 rather than Elements. Thank you so much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2019 0
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

Hey Jeff,

     Thank you so much for posting this solution! I had the same problem using Premiere Elements 11 on a new Dell XPS running Windows 10 - the menus within the program were almost unreadable. Your solution quickly fixed my problem.

     It would be nice if there was some way to make your solution more widely known Jeff. I'm sure many of us who use older versions of Premiere Elements have the same problem. We really like the software, and want to keep using it. But to mess with the registry, as suggested in some forums, is probably not something most of us should be doing. Or to be told, as in most forums, that we "simply have to upgrade to the newest version" is frankly, insulting for those of us who have already paid dearly for this product. I would recommend Adobe stop alienating their customers with this kind of advice.

     So yeah, if there's some way your solution could be made more prominent for the search engines that would be great! It would be really nice if people like me could just google something like "premiere elements text/menu size too small" and quickly find your helpful post. Again, thanks for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 30, 2020 0
New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

I tried to do this for premiere elements but still can't get it to change the size of the UI. So small, I can barely do anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

You should ask about it over in the Premiere Elements forum

 

https://community.adobe.com/t5/premiere-elements/bd-p/premiere-elements

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
New Here ,
Sep 15, 2019

Copy link to clipboard

Copied

Windows 10 using PSE 2 and PSE 10.

Icon size OK on PSE 2 but too small on PSE 10. However I decidied to uninstall and then renstall PSE 10, the small icon size remains and I now have a further problem: I get the PSE 10 screen OK but as soon as I click File the whole PSE 10 disappears. Re loading it just causes a repeat.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2019 0
sipson LATEST
New Here ,
Aug 26, 2020

Copy link to clipboard

Copied

Thanks for this solution. Adobe needs to AT LEAST promote this so that it is found in a FAQ or something promonent. I have a 1920x1080 13" monitor on my Samsung notebook and Elements was the only one giving me menu font size problems. It was almost unusable. Frankly, there should be provisions for this in the Preferences options. At least I didn't have to fire up Tor and search the Dark Web to find your solution, but it seemed that way.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0