Highlighted

Importing to Elements 2020

New Here ,
Oct 22, 2020

Copy link to clipboard

Copied

I have recently purchased the Elements 2020 suite. I am importing my photos into albums, in blocks of 100 at a time from a flash drive. On three ocasions these imports have told me to "Reconnect". I have done this but the fix is only temporary. I was able to view the thumbnails, the expanded view was available after cancelling the reconnect message, the full screen view was unavailable. Deleting the program from my system and reinstalling does not help. I have now deleted the offending 300 images but cannot reinstall because a message appears telling me that they are already in the catalouge. Can I delete these files completely? Can I hard-reboot the system and start again? I am running the latest OS Catalina on a Macbook Pro. Please help.

TOPICS
Problem or error

Views

61

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing to Elements 2020

New Here ,
Oct 22, 2020

Copy link to clipboard

Copied

I have recently purchased the Elements 2020 suite. I am importing my photos into albums, in blocks of 100 at a time from a flash drive. On three ocasions these imports have told me to "Reconnect". I have done this but the fix is only temporary. I was able to view the thumbnails, the expanded view was available after cancelling the reconnect message, the full screen view was unavailable. Deleting the program from my system and reinstalling does not help. I have now deleted the offending 300 images but cannot reinstall because a message appears telling me that they are already in the catalouge. Can I delete these files completely? Can I hard-reboot the system and start again? I am running the latest OS Catalina on a Macbook Pro. Please help.

TOPICS
Problem or error

Views

62

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 22, 2020 0
Explorer ,
Oct 22, 2020

Copy link to clipboard

Copied

First: welcome to the flock! 😉  I recently purchased Photoshop Elements myself as well (quite happy with it) but please keep my "newbie'ism" in mind, doing my best to help but.. yah.

 

"I am importing my photos into albums, in blocks of 100 at a time from a flash drive. On three ocasions these imports have told me to "Reconnect". I have done this but the fix is only temporary."

 

Why batches of 100? The first thing you want to do is get all your media imported within Organizer. See, the idea is to let Organizer 'collect' all your media files so it can build up its database after which you can use that database to actually sort out your images by creating virtual albums (for example; there are tons of other ways in which you can sort your images as well).

 

Now, it is possible that some images may cause problems. For example they won't show up in your Organizer, not even if you double click to open them in the viewer. There are solutions for this; one option could be to (bulk) edit them with the Editor after which they should be fixed.

 

Second: don't re-install software. In pretty much most cases it's completely useless. See: while you may remove the software you're usually leaving your settings intact. And in most cases (not all!) it's those settings which can cause your issues. As a rule of thumb: don't bother. If you really want to reset things then remove the settings, not the software.

 

"I have now deleted the offending 300 images but cannot reinstall because a message appears telling me that they are already in the catalouge."

 

Please bear in mind that although I have a very good idea what is going on I'm obviously not 100% sure. This won't be destructive but I cannot guarantee that it'll help. But lets see how far we can go...

  • Open your Organizer and don't keep any folders selected. You should see all your imported images.
  • Use the following menu option: Search => Locate all missing files (so: open the search menu and use the appropriate entry).

Now you should get an overview of all images which are in your catalog but which the Organizer cannot find on disk. Select them all and then remove the whole lot. This should fix your issues.

 

You should then be able to re-import them.

 

Hope this can help for now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0
Explorer ,
Oct 22, 2020

Copy link to clipboard

Copied

Sorry for a quick second post but it seems I cannot edit my previous post (I need to get used to that) and this is still important:

 

In addition to the above: when I mentioned "remove the whole lot" I am obviously only referring to your catalog. Do not select the option to also remove them from the disk because that would destroy the originals as well, which isn't what we want here. It should be obvious enough but I still wanted to add this disclaimer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2020 0
Adobe Community Professional ,
Oct 24, 2020

Copy link to clipboard

Copied

"Do not select the option to also remove them from the disk because that would destroy the originals as well, which isn't what we want here. It should be obvious enough but I still wanted to add this disclaimer."

When you delete missing files from catalog, there is no risk for the real disconnected files to be physically deleted since the catalog does not find them. If you tick the checbox to also delete from disk, that will be ignored.

Removing missing files from the catalog:

- search for missing files, the list is displayed on the left of the dialog.

- on top, there is a small icon (3 horizontal bars) which opens the contextual menu

- choose select all

- choose delete all (be patient...)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 0
New Here ,
Oct 23, 2020

Copy link to clipboard

Copied

Thank you for your replies. I have traditionally stored my images in folders or albums of 100, in date order. They were stored on my MacBook in the now sadly defunct Apple Aperture program. They are doubly backed up on flash drives, 2000 per drive. I did initially import the complete 2000 images to Organiser but instead of selecting 100 at a time to put in the album, I found it easier to import 100 at a time, select all and move.

I did search/locate/delete all missing files but was unable to re-import them because they were “unsupported" or “already in your catalogue”. I am now thinking of deleting the whole catalogue and starting again. Is there a way to hard-reboot Organiser?

Once again, thank you for you time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Adobe Community Professional ,
Oct 24, 2020

Copy link to clipboard

Copied

"I did search/locate/delete all missing files but was unable to re-import them because they were “unsupported" or “already in your catalogue”. I am now thinking of deleting the whole catalogue and starting again. Is there a way to hard-reboot Organiser?"

You can check if files are not supported by trying to import them in a new catalog.

If you delete "all missing files" as described in my other post, you should be able to reimport them from their present location if you know it.

Let's say you have a file for which the organizer says it's already in the catalog. Take a note of the exact 'date_taken' and the size in kB. Do a search for all files taken plus or minus one hour around that time and search visually to find if there is a corresponding file in the search result.

You can delete the whole catalog or simply ignore it and create a new one.

If you want to reimport, you can first 'write metadata to files' before reimporting. You can even save your keyword hierarchy to a small text file and restore it in the new empty catalog before reimporting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 0
Adobe Community Professional ,
Oct 24, 2020

Copy link to clipboard

Copied

"On three ocasions these imports have told me to "Reconnect". I have done this but the fix is only temporary. I was able to view the thumbnails, the expanded view was available after cancelling the reconnect message, the full screen view was unavailable."

My guess is that you may have imported the files in a different way for those ocasions. Importing from a flash drive may have been from 'Import from files or folders" like for a USB external drive, or 'from camera or card reader'. In one case, you have the option to create previews on your internal drive which give you a bigger size than a regular thumbnail. Depending on how you imported, the files are seen as either 'missing' or 'offline', which require a different solution.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 0
Adobe Community Professional ,
Oct 24, 2020

Copy link to clipboard

Copied

@ShelLuser, you can edit a reply by clicking on the elipsis More button at the bottom of the post.  Please let me know if this is not working for you, as I'm not sure whether this only applies to moderators.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 0
Explorer ,
Oct 24, 2020

Copy link to clipboard

Copied

"Please let me know if this is not working for you, as I'm not sure whether this only applies to moderators."

 

When I click that option I only get to see an empty pop-up and that's it. I've also tried this within in-private mode (to ensure this wasn't caused by a plugin) and I've also tried another browser (I use both Opera & Edge) but also to no avail.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 0