Highlighted

Issues with facial recognition in Elements 2018

Community Beginner ,
Dec 22, 2019

Copy link to clipboard

Copied

So I have been using PhotoShop Elements organiser for several generations now, and have experienced similar issues back to at least Version 2015.   Addmittedly I am running on very old hardware.  When going over a face, the software pops up the message "Is this Person".  I have never had issues if I click the check mark for yes, but have had MANY issues if I click the X for no;  Generally nothing happens;  especially lately (running version  2018) but only after the August Microsoft Updates (which according to logs "migrated my display driver....more installation still required"???); the characteristic response to clicking the "X" has changed.  I now get one of several:  1) the arrow turns to a fist & nothing happens, returning to an arrow in a few seconds, 2) the question turns to "Is this Person2?"; If you click the "X" again you ALWAYS get response 1);  3) The arrow turns to a fist, and after a long wait, the question turns to "Name this person", which then works, or 4) more commonly than 3), the Face/photo closes out and returns you to the "GRID" that you orginally opened this face from.  I have over 4500 photos of a single person in my Catalog, and over 68,000 photos total.  Most of my chinese in-laws.  This facial recognition program leaves a lot to be desired!  Laterly I am suffering many memory/read related issues, which I don't know if are due to the Adobe or MS software, or hardware.  These include duplicating rows of face circles in the Named People page, and even splitting face circles top half/bottom half of two different people after clicking the show faces for a single person, then expanding the 999+ circle.  I have just ordered new hardware and will be updating elements when I get that.  Is there a limit to how many identified single person photos you can have in a catalog?  most of these issues with the memory reads, started when I went over 4096 photos of my wife!

TOPICS
Bug, Organizer, Performance

Views

79

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Issues with facial recognition in Elements 2018

Community Beginner ,
Dec 22, 2019

Copy link to clipboard

Copied

So I have been using PhotoShop Elements organiser for several generations now, and have experienced similar issues back to at least Version 2015.   Addmittedly I am running on very old hardware.  When going over a face, the software pops up the message "Is this Person".  I have never had issues if I click the check mark for yes, but have had MANY issues if I click the X for no;  Generally nothing happens;  especially lately (running version  2018) but only after the August Microsoft Updates (which according to logs "migrated my display driver....more installation still required"???); the characteristic response to clicking the "X" has changed.  I now get one of several:  1) the arrow turns to a fist & nothing happens, returning to an arrow in a few seconds, 2) the question turns to "Is this Person2?"; If you click the "X" again you ALWAYS get response 1);  3) The arrow turns to a fist, and after a long wait, the question turns to "Name this person", which then works, or 4) more commonly than 3), the Face/photo closes out and returns you to the "GRID" that you orginally opened this face from.  I have over 4500 photos of a single person in my Catalog, and over 68,000 photos total.  Most of my chinese in-laws.  This facial recognition program leaves a lot to be desired!  Laterly I am suffering many memory/read related issues, which I don't know if are due to the Adobe or MS software, or hardware.  These include duplicating rows of face circles in the Named People page, and even splitting face circles top half/bottom half of two different people after clicking the show faces for a single person, then expanding the 999+ circle.  I have just ordered new hardware and will be updating elements when I get that.  Is there a limit to how many identified single person photos you can have in a catalog?  most of these issues with the memory reads, started when I went over 4096 photos of my wife!

TOPICS
Bug, Organizer, Performance

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 22, 2019 0
Adobe Community Professional ,
Dec 22, 2019

Copy link to clipboard

Copied

Clayton, there is no limit to the number of faces of the same person that you can have in a single person stack.  I have over 17,000 faces of my grandson in one catalog stack and several other stacks with over 10,000 faces.  However, I am seeing several of the problems that you have observed.  I suspect this may have to do with a Windows update 'cos I'm seeing them on Elements 2019 and 2020 and never saw them before.

 

However, I suggest that you name your stacks of People in the UnNamed People tab rather than by clicking on each individual photo or using the "Is this X?" in the Named People room.

 

Finally, I am going to branch this discussion off from the main thread so that your concerns will have more visibility.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 22, 2019 0
Community Beginner ,
Dec 23, 2019

Copy link to clipboard

Copied

Just to update the comments on my 'archaic' system:  

I am running an Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz with 8GB RAM; My Graphics card is a NVIDIA GeForce GT-620 with the latest (3/23/18) Nvidia Driver;  OS is the Windows 10 Home Version 1909 which installed on 8/8/2019.

Shortly after this windows install I got several messages when I started Elements stating that I had the default Windows display driver and it may not operate fully.  I installed the above Nvidia driver and the message, but not the issues went away.  About that time, I also had one pop-up stating a buffer overflow occured and crashed the Elements.

According to another Blog I was researching, MS claimed to support the GT-620, but another user pointed out that this card did not support DirectX version 12 and wondered how they could claim it was supported.  I suspect as they assign their default driver to it they consider that support, however that appears not good enough to support Elements!

I do believe that the 8/8 build of windows brought many new issues.  I am awaiting my new hardware (backordered) which probably won't arrive until after the first of the year.  Most of the issues are either with memory reads & displays, or with the interaction of mouse/cursor and the display. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 23, 2019 0