Highlighted

Lag in Photoshop Elements on MacBook

New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

I have a trial version of Photoshop Elements on a MacBook Pro 16 running macOS Catalina
There is a 2-3 second lag time from when I select an item to when it is actually selected. If I try to scroll my images, I have to wait 2-3 seconds after every scroll before I can continue with the scroll.

How can I correct this lag? It is very irritating.

Hi there,

 

We are sorry about the experience with Photoshop Elements on your MacBook.

 

Please go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy Tab. Then select Accessibility from the list on the left and add Photoshop Elements to the list after unlocking the window using the lock on the bottom left. Also, grant permissions to Photoshop Elements under Full Disk Access. Once done, restart the computer and check if that helps.

 

You can also go to the Preferences for Photoshop Elements, then Performance, then uncheck the option to Use Graphics Processor and increase the Memory Usage to 75-80%. Once done, relaunch Photoshop Elements and check if that helps.

 

Rehards,

Nikunj

TOPICS
Mac, Performance, Problem or error

Views

178

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lag in Photoshop Elements on MacBook

New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

I have a trial version of Photoshop Elements on a MacBook Pro 16 running macOS Catalina
There is a 2-3 second lag time from when I select an item to when it is actually selected. If I try to scroll my images, I have to wait 2-3 seconds after every scroll before I can continue with the scroll.

How can I correct this lag? It is very irritating.

Hi there,

 

We are sorry about the experience with Photoshop Elements on your MacBook.

 

Please go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy Tab. Then select Accessibility from the list on the left and add Photoshop Elements to the list after unlocking the window using the lock on the bottom left. Also, grant permissions to Photoshop Elements under Full Disk Access. Once done, restart the computer and check if that helps.

 

You can also go to the Preferences for Photoshop Elements, then Performance, then uncheck the option to Use Graphics Processor and increase the Memory Usage to 75-80%. Once done, relaunch Photoshop Elements and check if that helps.

 

Rehards,

Nikunj

TOPICS
Mac, Performance, Problem or error

Views

179

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 10, 2020 0
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

Moved to the Photoshop Elements forum, from the Photoshop forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2020 0
Adobe Employee ,
Apr 10, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry about the experience with Photoshop Elements on your MacBook.

 

Please go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy Tab. Then select Accessibility from the list on the left and add Photoshop Elements to the list after unlocking the window using the lock on the bottom left. Also, grant permissions to Photoshop Elements under Full Disk Access. Once done, restart the computer and check if that helps.

 

You can also go to the Preferences for Photoshop Elements, then Performance, then uncheck the option to Use Graphics Processor and increase the Memory Usage to 75-80%. Once done, relaunch Photoshop Elements and check if that helps.

 

Rehards,

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2020 0
New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

I changed the Preferences for Photoshop Elements and it worked. It is so much better now. Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2020 0