Highlighted

Photoshop Elements (17.0) not detecting correct GPU

New Here ,
Jun 01, 2019

Copy link to clipboard

Copied

I've had Photoshop Elements for about half a year now, and it's great for my purposes, but one thing has irked me; on my Surface Book 2, it's not detecting my GPU (GTX1060). it's only using the integrated graphics chip. Other programs on my laptop don't have a problem switching to the GTX when I'm in Best Performance mode. I don't know if there's a way to manually select the graphics card. It's just not changing, and I think the performance of the program could be better if I had it.

Please help. Thanks!

[ moved from Photoshop to Photoshop Elements by moderator ]

Views

108

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop Elements (17.0) not detecting correct GPU

New Here ,
Jun 01, 2019

Copy link to clipboard

Copied

I've had Photoshop Elements for about half a year now, and it's great for my purposes, but one thing has irked me; on my Surface Book 2, it's not detecting my GPU (GTX1060). it's only using the integrated graphics chip. Other programs on my laptop don't have a problem switching to the GTX when I'm in Best Performance mode. I don't know if there's a way to manually select the graphics card. It's just not changing, and I think the performance of the program could be better if I had it.

Please help. Thanks!

[ moved from Photoshop to Photoshop Elements by moderator ]

Views

109

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 01, 2019 0
Adobe Community Professional ,
Jun 01, 2019

Copy link to clipboard

Copied

I know of no way to select the graphics card.  I assume you have found the Preferences>Performance tab and seen which graphics card has been detected.

Snap10_2019.06.01_10h50m51s_002_.png

The only other thing I can suggest is to disable the integrated chip in the OS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2019 0
Adobe Community Professional ,
Jun 02, 2019

Copy link to clipboard

Copied

I have already seen a similar question which I can't find now, but the solution was probably what Greg suggests, disabling the chip in the OS.

I think the performance of the program could be better if I had it.

Wrong.

The GPU is extremely rarely used in Photoshop Elements (it is in Premiere Elements). On the contrary, it may be a source of various compatibility issues. The general consensus to choose your hardware for Elements is to favour first RAM size, then processor speed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2019 0