Highlighted

Photoshop Elements 2019 error after upgrading to Catalina.

New Here ,
Oct 12, 2019

Copy link to clipboard

Copied

I am getting the error: Your application install seems to be damaged, Please reinstall the application.

I have uninstalled using the adobe install app & reinstalled, but I'm still getting the error.

Views

81

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop Elements 2019 error after upgrading to Catalina.

New Here ,
Oct 12, 2019

Copy link to clipboard

Copied

I am getting the error: Your application install seems to be damaged, Please reinstall the application.

I have uninstalled using the adobe install app & reinstalled, but I'm still getting the error.

Views

82

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 12, 2019 0
Adobe Community Professional ,
Oct 12, 2019

Copy link to clipboard

Copied

PSE 2019 is not compatible with Catalina.

PSE 2020 is compatible with Catalina.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2019 0
Adobe Community Professional ,
Oct 12, 2019

Copy link to clipboard

Copied

What Peru Bob said.

 

You'll have to pay to upgrade to Elements 2020.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2019 0
Adobe Employee ,
Oct 13, 2019

Copy link to clipboard

Copied

Hello,

 

The licensing component of Photoshop Elements 2019 isn't compatible with macOS Catalina. To use Photoshop Elements 2019, you can either install it on a system running macOS Mojave 10.14, or you can reach out to us at Grp-ElementsSupport@adobe.com and someone from the team would assist you with the installation process.

 

Thanks,

Medha

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2019 0