Highlighted

Photoshop Elements 2020.1 not compatible with high res screen

Community Beginner ,
Apr 15, 2020

Copy link to clipboard

Copied

I run Windows 10 on my iMac. The screen resolution is 5120 x 2880... with scaling set at 200%. These are the recommended settings.

 

However, Photoshop Elements is all messed up. Where certain buttons and controls should be in the app... they are missing. Instead there is just black space. The program is virtually unusable because of all the missing controls. Any ideas as to a fix?

 

I've attached a screen capture of the bottom of the program where some controls should be.

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Go to

 

C:\Program Files\Adobe\Photoshop Elements 2020

 

right click on the

 

PhotoshopElementsEditor.exe

 

select Properties>Compatibility>Change high DPI settings and enable High DPI scaling override to System or System Enhanced and see if that makes any difference.

 

Screenshot-(235).png

TOPICS
Bug, Problem or error, Windows

Views

265

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop Elements 2020.1 not compatible with high res screen

Community Beginner ,
Apr 15, 2020

Copy link to clipboard

Copied

I run Windows 10 on my iMac. The screen resolution is 5120 x 2880... with scaling set at 200%. These are the recommended settings.

 

However, Photoshop Elements is all messed up. Where certain buttons and controls should be in the app... they are missing. Instead there is just black space. The program is virtually unusable because of all the missing controls. Any ideas as to a fix?

 

I've attached a screen capture of the bottom of the program where some controls should be.

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Go to

 

C:\Program Files\Adobe\Photoshop Elements 2020

 

right click on the

 

PhotoshopElementsEditor.exe

 

select Properties>Compatibility>Change high DPI settings and enable High DPI scaling override to System or System Enhanced and see if that makes any difference.

 

Screenshot-(235).png

TOPICS
Bug, Problem or error, Windows

Views

266

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 15, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

Do you have the taskbar set to hide automatically?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

Taskbar? Where would I find settings for a taskbar in Photoshop Elements?

 

These missing controls are at the bottom of the Photoshop Elements screen, and also at the top.

 

In general... when I mouse over the controls, they appear.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

Sorry, I focused on you using Windows 10.  I didn't notice that you are using a virtual machine in iMac.  The taskbar control is a right-click in Windows.  I have no idea what happens on an iMac.  And why are you not using the native Mac program for Elements?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

I am not using a virtual machine on my iMac. I am running Windows on my iMac natively. This is why I'm not using the Mac version of Photoshop Elements. Because I am not running macOS on my iMac.

 

So anything that applies to Windows 10 will also apply to me... since I'm running Windows 10.

 

So back to my question... are you referring to some taskbar setting in Photoshop Elements? This is where I am lost.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

I should also clarify... my screen capture did not show the Windows taskbar. My screen capture was showing the bottom of the Photoshop Elements window. The Windows taskbar is not shown. I don't think Windows taskbar settings are a factor in the issue I'm experiencing. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

A 5K monitor is unusual hardware for an Elements user.  I suspect the developers didn't do much testing with it.

 

Have you tried using different OS scaling?  Perhaps 150% instead of 200.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

Yep. I do believe the 5K monitor is the root of the issue. I will try using 150% tonight and post the result. Thanks for the suggestion.

 

I do see, in the Photoshop Elements preferences, where I can set the zoom level manually. Setting it to 200% didn't help. And there is even a warning on that panel indicating potential problems with doing so.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

Changing the scaling in the Windows settings did no good. BUT... when I changed the settings in Photoshop Elements to force it to 100%, my specific problem went away. So the various controls are all visible. But they are very small. Because everything on my screen is zoomed to 200% but the Photoshop Elements UI is set to 100%.  (see attachment)   I would not really consider this a solution, but it is a work-around. If the Photoshop Elements UI could successfully zoom to 200% I don't think I would have any problem. But here, even by their own admission... it doesn't work. 

 

Annotation 2020-04-16 180958.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 18, 2020

Copy link to clipboard

Copied

Go to

 

C:\Program Files\Adobe\Photoshop Elements 2020

 

right click on the

 

PhotoshopElementsEditor.exe

 

select Properties>Compatibility>Change high DPI settings and enable High DPI scaling override to System or System Enhanced and see if that makes any difference.

 

Screenshot-(235).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2020 1
eldenf LATEST
Community Beginner ,
Apr 18, 2020

Copy link to clipboard

Copied

Thank you for the tip Jeff. I will give that a try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2020 0