Photoshop Elements 2020 won't load photo editor

New Here ,
Dec 04, 2019 Dec 04, 2019

Copy link to clipboard

Copied

So I have been needing to use the photoshop app for a while but all of a sudden it will not open. it says it is loading, but just stops loading after about 20 seconds. I have used it before and am on windows 10. I have tried some of the basic fixes ( opening task mangager and closing backround adobe, clearing prefrences, restarting my computer ect.). could someone help me so I can go back to using it?

TOPICS
Crash or freeze, Performance, Problem or error

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 04, 2019 Dec 04, 2019

Copy link to clipboard

Copied

Hello,

 

Could you please navigate to "C:\Program Files\Adobe\Photoshop Elements 2020", double-click on the "PhotoshopElementsEditor.exe" and confirm if the Editor launches successfully?

 

Thanks,

Medha

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2019 Dec 14, 2019

Copy link to clipboard

Copied

Medha (or to whom it may concern?), 

I'm having the same issue with 2020 loading. Tried what you suggested and got nothing. Tried the chat support only to wait hours (multiple days) with no help.

Any help will be appreciated.
Buddy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 15, 2019 Dec 15, 2019

Copy link to clipboard

Copied

Hello,

 

Could you please check if any instances of Photoshop Elements are running in the Task Manager? If so, then please close them and then try launching the 'PhotoshopElementsEditor.exe' by double-clicking on it.

 

Thanks,

Medha

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

Hi, I did this and it still won't launch. I've tried deleting the file and reinstalling it as well. The only program that seems to be functioning properly is Premiere Elements 2020

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

It's probably a better idea to start a new thread of your own because it remains to be seen if all these problems are fully related.

 

First: what exactly happens?  Do you see a splashscreen or not? Do you have Premiere as well by any chance and if so: does that work?

 

Also..  I'm assuming the process has stalled, but how long do you wait? If you check your task manager does it mention anything about the process being stalled or does it run normally?

 

Finally: are you using the latest version of your OS< with all the security patches and such? I mean.. if you're using this on XP, Vista or Windows 7 then you're probably pretty much on your own because there are a lot of possible causes. Otherwise....

 

When all else fails you could try to move your settings out of the way to see if that helps. So... open a file manager, go to %APPDATA%, find the 'Adobe' directory and either rename the whole directory or rename the 'Elements' folder invite. Then try to start the program again to see if this changes anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

Hi WIZARDPhotography58, I am having the same problem . Did you get any help eventually? What did you do to solve this? Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

(Sorry this awnser took so long I didn't get a notification) I have tried this, When I click it, my cursor shows that it is loading for about a second, then it just stops and nothing happens. Does it matter that I moved it to a different drive because my main drive didn't have enough space at the time? (I have more than 15 gigs now in the main drive.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2020 Jul 11, 2020

Copy link to clipboard

Copied

I am having the same problem. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

Hi there, same here. That happened after I'd been asked to do an update. Nobody is answering on Chat online.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2020 Jul 09, 2020

Copy link to clipboard

Copied

I have the same issue on a Mac running Catalina.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2020 Sep 29, 2020

Copy link to clipboard

Copied

PLease can someone advise if a solution has been found? I have not been able to open my Photoshop Editor in months.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Same issue is happening to me.  tried all the fixes suggest and still won't open. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2020 Oct 15, 2020

Copy link to clipboard

Copied

Photoshop Elements is not loading photo editor on my Mac either.   I am running on Catalina.  I can't get it to launch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

Hi!

I just started having the same problem with editor. Just wondering if u got a solution that does work???

 

Thanks!!!

 

Paul

 

pssandler@comcast.net

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

Hi Paul,

 

Probably best to start a new post and give us a few more details about your specific problem.

 

Please include in your post:

 

- your version of Photoshop Elements

- your operating system and version

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

I was using Photoship Elements 2020 too on my Mac Big Sur 11.2.3 as well and the photo editor stopped working today, too.

I have reinstalled several times and nothing.  The Editor workspace starts to be created and then it stops.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Late response, I'm well aware, but I'd like to mention that I think Adobe finally fixed this whole mess.

 

I've been very inactive on this community as of late and the main reason for that was this mess. I could basically (or re-install) Photoshop Elements 2020 every single week because it refused to start (it would stall as the OP mentioned). Eventually things changed (this was a several weeks ago) and I no longer had issues with PSE freezing to start, but now it would constantly crash whenever I tried to shut it down. Forget about a prompt asking you to save, instead you got the crash form. I sent a few reports in but eventually stopped bothering because it became "normal". Needless to say that this wasn't helping my motivation to participate very much (I live by "If you don't have anything nice to say then maybe not say anything at all? (except where it's ontopic of course)) and I also wasn't so happy with my purchase anymore. Not necessarily negative, but...

 

Premiere Elements never had an issue and saw an update, PSE on the other hand... 😒

 

BUT... they fixed it. I got a PSE update which was more than a week ago and right now I get to enjoy the whole suite again. It starts normally, I no longer had any crashes during shutdown since the update and I finally get to enjoy myself using this software again. Although I'm not too positive about the time it took to fix all this I am happy to see that it finally happened and well... My admiration for the software itself never changed; I (still) think working with PSE is amazing. I used Gimp before but I'm not looking back.

 

Figured I'd share.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

I am having the exact problem launching the Photo Editor. I purchased and downloaded PSE 2020 a few months ago from Adobe online but wanted to take a PSE course before trying to use it. Now, when I try to open it up, you can see that it it trying to but then stops. During that process, a small window opens up with an offer to try the 1-month free trial. I don't want that....I have already purchased the program!! If I open Organizer and try to connect to the Editor from that page, it does the same thing.

At the suggestion mentionned below, I downloaded 'C:\Program Files\Adobe\Photoshop Elements 2020" but nowhere was there an option to connect to "PhotoshopElementsEditor.exe"

My computer is just a few months old. There are no previous PSE programs installed on the computer. My Windows 10 version is updated 

Could someone please help as I have spent hours trying to resolve this. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Still looking for help in launching the Photoshop Elements Photo Editor & Video Editor. The Organizer opens. I read that there is an update.available. Anyone know where I can get this? Cannot seem to get a response from any Adobe "tech folks". Have spent hours and hours resolving this with no luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Hallo,

seit einigen Wochen habe auch ich das Problem, dass - wenn ich im Organizer der Editor aktiviere - einige Zeit lang angezeigt wird, dass der Editor geladen wird, danach verschwindet die Anzeige. Als Umgehungslösung starte ich den Editor aus dem Programmverzeichnis und öffne dort die gewünschten Bilder. Mein Programm ist auf aktuellem Stand. Drüberinstallieren bringt keine Änderung.

Ich ersuche um eine Lösung.

Freundliche Grüße

Hannes Petschl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

I too am having the same problem.  I am using PSE 2020 Premium in Win 10 and a Dell Inspiron 5000 series 1 year old computer.    Elements Editor will not load.  I tried to go to PhotoshopElementsEditor.exe and nothing happened.  I need some help and advice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Hi,
see workaround below
best regards
Hannes

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

I haven't used it for a while and after reading this forum, I opened my PSE 2020 editor, it's spinning and nothing happened. They srcewed it up to force you to buy a cloud plan.  This is bad practice. CEO wants more bonuses on profit. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Hi,
Just yesterday I tried to start Adobe Photoshop 2020 Elements with administrator rights. This workaround worked, I can now start the editor again from the user interface.
best regards
Hannes

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines