Photoshop elements suddenly super slow on Macbook Pro / iOS Mojave

Community Beginner ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

Since one week Photoshop elements runs extremely slow on my Macbook Pro.

Any ideas, how I may fix this? 

It used to run like a charm. I did not change the iOS (Mojave) or anything else. 

 

Thank you so much! 

 

TOPICS
Mac, Performance

Views

348

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Employee , Jun 03, 2020 Jun 03, 2020
Hi there, Sorry that Photoshop Elements is running slowly unexpectedly on your Mac running macOS Mojave. Which version of Photoshop Elements are you using and when exactly is it running slow? Would you mind checking the steps mentioned in this article https://helpx.adobe.com/photoshop-elements/kb/troubleshoot-system-errors-freezes-photoshop.html and let us know if that helps? Thanks, Akash

Likes

Translate

Translate
Community Beginner , Jun 03, 2020 Jun 03, 2020
Elements 12. I was able to solve the problem through a restart, resetting the PRAM.So it seems the RAM on my mac was full. It didn't effect any other programs, only Elements. But it seems the problem was not with Elements itself. Now it's working fine again. 

Likes

Translate

Translate
Adobe Employee ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry that Photoshop Elements is running slowly unexpectedly on your Mac running macOS Mojave.

 

Which version of Photoshop Elements are you using and when exactly is it running slow?

 

Would you mind checking the steps mentioned in this article https://helpx.adobe.com/photoshop-elements/kb/troubleshoot-system-errors-freezes-photoshop.html and let us know if that helps?

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

LATEST

Elements 12. 

I was able to solve the problem through a restart, resetting the PRAM.

So it seems the RAM on my mac was full. It didn't effect any other programs, 

only Elements. But it seems the problem was not with Elements itself. 

Now it's working fine again. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines