Highlighted

Printing from Elements2018 to Epson R3000 Ink jet printer.

Explorer ,
May 31, 2020

Copy link to clipboard

Copied

I have been using my Epson Stylus Photo R3000 inkjet printer with no problems for a few years.

I print from within Elements 2018. I have Window 10 as my operating system.

I shoot in RAW, process in ACR and edit in Elements Editor.   

I have suddenly developed a problem with setting the colour mangement to be handled by the printer.

My printer is set up as follows: 

In the printer properties menu                                                    Mode is set to Adobe RGB 

In the More Options menuavailable from the Print menu     Colour Management is set to "Printer manages Colours"

There is a warning message "Did you remember to enable color mamagement in the printer preference dialog"

In the Printer Properties menu,I can find no field for "enable color mamagement" but the Mode field has changed to Off ( no color adjustment). I had previously set it to Adobe RGB. 

I then returned to the More Options menu, Color Management is still set to "Printer manages Colours"

I have spent hours today trying to sort this out, I have read evertyhing I can find on Color Management on the Web. I must have inadvertantlychanged a setting somewhere that has caused mr this grief.

Help would be much appreciated.

 

 

 

 

 

Adobe Community Professional
Correct answer by hatstead | Adobe Community Professional

I don't have PSEv.18, but I do have an Epson printer.

In Editor, go to Edit menu>Color Settings, and check "Always Optimize for Computer Screens."

Then, go to File>print>More options>Color Management tab. Color Handling>"Printer Manages Colors."

That should to it. 

Further to above, turn on your printer and right click on thr Epson printer icon on the taskbar. Go to Printer Settings>Properties and check "Color."

Under More Options, the default is  Color Correction>Automatic.

 

TOPICS
Problem or error

Views

260

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Printing from Elements2018 to Epson R3000 Ink jet printer.

Explorer ,
May 31, 2020

Copy link to clipboard

Copied

I have been using my Epson Stylus Photo R3000 inkjet printer with no problems for a few years.

I print from within Elements 2018. I have Window 10 as my operating system.

I shoot in RAW, process in ACR and edit in Elements Editor.   

I have suddenly developed a problem with setting the colour mangement to be handled by the printer.

My printer is set up as follows: 

In the printer properties menu                                                    Mode is set to Adobe RGB 

In the More Options menuavailable from the Print menu     Colour Management is set to "Printer manages Colours"

There is a warning message "Did you remember to enable color mamagement in the printer preference dialog"

In the Printer Properties menu,I can find no field for "enable color mamagement" but the Mode field has changed to Off ( no color adjustment). I had previously set it to Adobe RGB. 

I then returned to the More Options menu, Color Management is still set to "Printer manages Colours"

I have spent hours today trying to sort this out, I have read evertyhing I can find on Color Management on the Web. I must have inadvertantlychanged a setting somewhere that has caused mr this grief.

Help would be much appreciated.

 

 

 

 

 

Adobe Community Professional
Correct answer by hatstead | Adobe Community Professional

I don't have PSEv.18, but I do have an Epson printer.

In Editor, go to Edit menu>Color Settings, and check "Always Optimize for Computer Screens."

Then, go to File>print>More options>Color Management tab. Color Handling>"Printer Manages Colors."

That should to it. 

Further to above, turn on your printer and right click on thr Epson printer icon on the taskbar. Go to Printer Settings>Properties and check "Color."

Under More Options, the default is  Color Correction>Automatic.

 

TOPICS
Problem or error

Views

261

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 31, 2020 0
Adobe Community Professional ,
May 31, 2020

Copy link to clipboard

Copied

I don't have PSEv.18, but I do have an Epson printer.

In Editor, go to Edit menu>Color Settings, and check "Always Optimize for Computer Screens."

Then, go to File>print>More options>Color Management tab. Color Handling>"Printer Manages Colors."

That should to it. 

Further to above, turn on your printer and right click on thr Epson printer icon on the taskbar. Go to Printer Settings>Properties and check "Color."

Under More Options, the default is  Color Correction>Automatic.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2020 0
Explorer ,
Jun 06, 2020

Copy link to clipboard

Copied

Thank you very much.

I apologize for not answering sooner, we are almost overwhelmed with the problems of re-opening after "lockdown".

 

The setting that caused all the problems was I had the following set-up Edit menu>settings  Check"Always optimize for printing" instead of " always optimize for computer screens"

Thank you your help and very concise instructions.

One small seeting, hours of frustration", not one article or tutorial on the web instructed me to set up this way.

Thank you again.

  

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2020 0
Adobe Community Professional ,
Jun 06, 2020

Copy link to clipboard

Copied

You're welcome. Glad to help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2020 0
Explorer ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi again Halstead,

I just want to confirm that what I have done is correct.

I am able to do everything you proposed except the instructions below "That should do it"

I opened the R3000 through the shot cut I have on the desktop ( there is no icon in the Task bar )

Not through the Elements Editor create option.

It opens on the "Settings" menu.

From the settings menu  >Properties   I can find no check box or option to check color.

There is however a " Colour Management" Tab, this opens the "Colour Management" menu 

in the "Devices" Tab. 

There is a Profile Selection field which is grayed out but has the message "Automatic ( Recommended ) 

I am sure if this were not greyed out there would be a drop down menu with more options.

There is however no "More Options"  option.

I will try and attach the relevant screen shots.

Have I done all that I require to do?

Colour Management.PNGEpson Stylus Photo R3000mProperties.PNG

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Community Professional ,
Jun 10, 2020

Copy link to clipboard

Copied

The display is different for my Epson WF2510. Sorry, but I can not help you with your equipment.

The bottom line is that you obtain quality prints. I have excellent color fidelity with Epson ink + Epson paper. I also have an old Lexmark printer which leaves much to be desired.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Explorer ,
Jun 12, 2020

Copy link to clipboard

Copied

Thanks for trying.

Just out of interest, do you  let the printer handle color management or does Photoshop/Lightroom fullfill this function?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
hatstead LATEST
Adobe Community Professional ,
Jun 12, 2020

Copy link to clipboard

Copied

Yes. Perinter manages color. PSE optimizes for computer screens. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0