Highlighted

PSE 2018 is sluggish

Community Beginner ,
Oct 03, 2020

Copy link to clipboard

Copied

Ever since I installed it, the program has been slow to respond, even to simple things such as ctrl backspace to fill a layer. It is slow enough that it is frustrating, especially since PSE 2012 responds instantly.  I have uninstalled and re installed 2018 and it is no better. If it were not for the grouping feature, I would permanently uninstall 2018.

 

Any suggestions?

TOPICS
Performance

Views

53

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PSE 2018 is sluggish

Community Beginner ,
Oct 03, 2020

Copy link to clipboard

Copied

Ever since I installed it, the program has been slow to respond, even to simple things such as ctrl backspace to fill a layer. It is slow enough that it is frustrating, especially since PSE 2012 responds instantly.  I have uninstalled and re installed 2018 and it is no better. If it were not for the grouping feature, I would permanently uninstall 2018.

 

Any suggestions?

TOPICS
Performance

Views

54

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 03, 2020 0
Adobe Community Professional ,
Oct 03, 2020

Copy link to clipboard

Copied

Are you talking about Elements 2018 or Elements 2020 (which is version 18)?  I ask because you say that you have just installed it.  If you have Elements 2018, did you acquire it from a reputable source?  What OS are you using?  Do you have Acronis True Image on your machine?  If so, I have seen it interfere with Elements and you need to exclude Elements from its "protection."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2020 0
Community Beginner ,
Oct 04, 2020

Copy link to clipboard

Copied

Thanks for your reply. I am referring to Elements 2018. I installed a while ago, have had the problem, and reinstalled yesterday, hoping to rectify it. I also have Elements 2012 and it does not have this problem. I wonder if the large number of layers, grouped, are just slowing the program down.

I am using Windows 10, and do not have Acronis True Image installed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0
Greg_S. LATEST
Adobe Community Professional ,
Oct 04, 2020

Copy link to clipboard

Copied

It is very difficult to diagnose your problem without more information.

There are a number of reasons that could account for what you are observing.  Are you saying that editing exactly the same file, with the same number and kind of layers is different between Elements 12 and 2018?  How much RAM do you have?  Is there sufficicient space on your system C drive ? (At least 10% free.)

Are you using the Organizer, and if so, how many files are in your catalog?  Have you recently added a significant number of new files?  Do you have auto-analysis turned on.  If so, many things could be going on in the background that could interfere with the Elements Editor.  Try turning auto-analysis off and see if it makes a difference.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2020 0