Re: Compatibilty APE2021 with Mac M1

Explorer ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

It is now 6 months since Apple releases Macs with the M1 chip and still there is nothing from Adobe about support for Photoshop Elements.   No comments as to whether it should or should not work with Rosetta translation and no word as to a timeline for native support on the M1.   This is not what I would call "actively working" on the issue.

Views

178

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

I have NO IDEA if this will fix your problem, but there is an update

https://community.adobe.com/t5/photoshop-elements/photoshop-elements-2021-2-is-now-available/td-p/11...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the comment John T Smith -- but this doesn't solve the problem.   I had already loaded this update back in March as did other posters on this thread, including michaelb6251476.   This March update does not provide a PSE Organizer update, only PSE photo editor is updated.   I am personally OK right now -- everything working fine on my MacBook Air M1 but, based on michaelb6251476's post, I am afraid to update my Mac to BigSur 11.3 until Adobe chimes in and tells us it should work.   Doesn't Adobe own a Mac M1 platform to run a few tests?   I think the company should be able to afford at least one.   Hello, Adobe, where are you?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines