Highlighted

Reconnecting external drive and offline files

Community Beginner ,
Jan 13, 2020

Copy link to clipboard

Copied

My photos are stored on an external drive which has failed. I have a new nas drive and have restored the files from a back up. I can't find how to reconnect the catalog to the new location. I've followed a variety of suggestions but nothing has worked. If I get to the screen which I think should fix it the option to reconnect drive is greyed out.

I have tried the approach to 'reconnect files' but as you can see from the second screenshot it's only reconnecting about 1% of the photos. It will find one in a folder but not all of them.

A further puzzle is that if I try to reconnect a single image I can't navigate to the folder on the nas drive as the dropdown (thrid image) only shows me local folders & I can't navigate to the external drive, even though it is connected, I can access it through finder and elements is finding a handful of image files. 

 

I'm on a Mac with Elements 14 and 80k photos. 

 

Any thoughts? 

 

 Screen Shot 2020-01-12 at 21.37.35.png

Screen Shot 2020-01-13 at 12.48.28.png

Screen Shot 2020-01-13 at 12.52.42.png

TOPICS
Organizer

Views

55

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Reconnecting external drive and offline files

Community Beginner ,
Jan 13, 2020

Copy link to clipboard

Copied

My photos are stored on an external drive which has failed. I have a new nas drive and have restored the files from a back up. I can't find how to reconnect the catalog to the new location. I've followed a variety of suggestions but nothing has worked. If I get to the screen which I think should fix it the option to reconnect drive is greyed out.

I have tried the approach to 'reconnect files' but as you can see from the second screenshot it's only reconnecting about 1% of the photos. It will find one in a folder but not all of them.

A further puzzle is that if I try to reconnect a single image I can't navigate to the folder on the nas drive as the dropdown (thrid image) only shows me local folders & I can't navigate to the external drive, even though it is connected, I can access it through finder and elements is finding a handful of image files. 

 

I'm on a Mac with Elements 14 and 80k photos. 

 

Any thoughts? 

 

 Screen Shot 2020-01-12 at 21.37.35.png

Screen Shot 2020-01-13 at 12.48.28.png

Screen Shot 2020-01-13 at 12.52.42.png

TOPICS
Organizer

Views

56

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 13, 2020 0

Have something to add?

Join the conversation