The developer of this app needs to update it to work with this version of macOS. Contact the develop

New Here ,
Nov 17, 2019 Nov 17, 2019

Copy link to clipboard

Copied

trying to install my Elements 15 on new computer and receiving this message. what do I do?

 

The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.

TOPICS
Mac

Views

425

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 17, 2019 Nov 17, 2019

Copy link to clipboard

Copied

LATEST

 

PSE 15 System Requirements:  Mac OS X v10.10, v10.11, or v10.12.  If your Mac doesn't meet these system requirements you'll need to purchase an upgrade (not to be confused with update).

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines