Highlighted

Trying to install photoshop Elements 9 on newer macosx

New Here ,
Mar 13, 2019

Copy link to clipboard

Copied

I do not want to upgrade to a newer version of PhotoShop because of the cost involved, I just do not use it very often.

It keeps saying, "this version of photoshop is not optimized for this OSX" then will not install.

Any ideas? This is an authorized version of Photoshop elements 9....just older.

Views

180

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Trying to install photoshop Elements 9 on newer macosx

New Here ,
Mar 13, 2019

Copy link to clipboard

Copied

I do not want to upgrade to a newer version of PhotoShop because of the cost involved, I just do not use it very often.

It keeps saying, "this version of photoshop is not optimized for this OSX" then will not install.

Any ideas? This is an authorized version of Photoshop elements 9....just older.

Views

181

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 13, 2019 0
Adobe Community Professional ,
Mar 13, 2019

Copy link to clipboard

Copied

Follow this to install pse 9. Just ignore the part about not optimized which has to do with the

next version of macOS not be able to run 32 bit applications like pse 9.

https://forums.adobe.com/message/9531901#9531901

32-bit app compatibility with macOS High Sierra 10.13.4 and later - Apple Support

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2019 1
Most Valuable Participant ,
Mar 13, 2019

Copy link to clipboard

Copied

Once you get it working, be sure you understand you must NEVER upgrade to the next Mac OS, 10.15. Your old software will NOT work, deliberately and intentionally, because Apple decided it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2019 0