Highlighted

Unable to export pics from camera to computer Elements

New Here ,
Oct 05, 2019

Copy link to clipboard

Copied

Hi everyone,

I had Adobe Elements 13, just upgraded to the latest. I have a Canon EOS7D.  I have not had any  problems previously downloading pics from my camera.  I just got a new cable, previous one was lost.  I started with my Elements 13 and then tried the Elements 20 and they both do the same thing.  I get all the way past the File/get photos/video, select my camera, get photos (it pulls up the pics) then when I click on get media at first it would do nothing, now I get an error message that says "Elements Organizer cannot obtain files from this device. Please ensure device is connected properly, or that the battery is charged, and try again.  Does this sound like the cable is defective?  I'm confused since it seems to get quite a ways before it locks up/error message.  Thanks in advance

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to export pics from camera to computer Elements

New Here ,
Oct 05, 2019

Copy link to clipboard

Copied

Hi everyone,

I had Adobe Elements 13, just upgraded to the latest. I have a Canon EOS7D.  I have not had any  problems previously downloading pics from my camera.  I just got a new cable, previous one was lost.  I started with my Elements 13 and then tried the Elements 20 and they both do the same thing.  I get all the way past the File/get photos/video, select my camera, get photos (it pulls up the pics) then when I click on get media at first it would do nothing, now I get an error message that says "Elements Organizer cannot obtain files from this device. Please ensure device is connected properly, or that the battery is charged, and try again.  Does this sound like the cable is defective?  I'm confused since it seems to get quite a ways before it locks up/error message.  Thanks in advance

Views

36

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 05, 2019 0
Adobe Community Professional ,
Oct 05, 2019

Copy link to clipboard

Copied

Moving from forum Community Help to Photoshop Elements.

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2019 0
Greg_S. LATEST
Adobe Community Professional ,
Oct 05, 2019

Copy link to clipboard

Copied

What OS are you using?  It may be that auto-analysis from your recent installation of 2020 is interfering with the process.  Try going into Edit>Preferences>Media Analysis and turn off all the check boxes.  Relaunch your computer and see if you have better luck with the import of photos from your camera. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2019 0