Highlighted

Upgraded from PSE 15 to 2020. Apps won't start

Explorer ,
Mar 11, 2020

Copy link to clipboard

Copied

I had a working installation of PSE 15.  I bought the upgrade version of PSE 2020 and installed.  Installation went fine, with no errors although it took about 20 minutes/

 

The launcher screen loads but I can't launch anything.  A spinner appears and disappears again and nothing happens.

 

I tried launching the editor exe directly from Windows Explorer - the same result.

 

What next please?

TOPICS
Problem or error, Windows

Views

57

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Upgraded from PSE 15 to 2020. Apps won't start

Explorer ,
Mar 11, 2020

Copy link to clipboard

Copied

I had a working installation of PSE 15.  I bought the upgrade version of PSE 2020 and installed.  Installation went fine, with no errors although it took about 20 minutes/

 

The launcher screen loads but I can't launch anything.  A spinner appears and disappears again and nothing happens.

 

I tried launching the editor exe directly from Windows Explorer - the same result.

 

What next please?

TOPICS
Problem or error, Windows

Views

58

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 11, 2020 0
Enthusiast ,
Mar 11, 2020

Copy link to clipboard

Copied

This isn't the typical user experience Paul, so why you and not everybody else right?  I hear you [sigh].  See if any of these troubleshooting tips get you out of Dodge.  Hope it helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2020 0
Explorer ,
Mar 11, 2020

Copy link to clipboard

Copied

Thanks Phinny - looks like I'm in for a long night. 🙂

 

While I was waiting for a reply,  I uninstalled and reinstalled everything, and updated the graphics drivers - to no avail. 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2020 0