Highlighted

What's the oldest Elements version I can use on Win10

New Here ,
Nov 09, 2020

Copy link to clipboard

Copied

I've used Photoshop 2.0 for Years, up to and including on my Win 7.  Sadly I can't use my Win 7 anymore, and 2.0 won't work on Win 10 (says it need more virtual memory - can I fix that?) .  I don't need fancy, the effects in 2.0 were just fine.  What's the oldest version of Elements I can use with Win 10?  Thanks

Adobe Community Professional
Correct answer by hatstead | Adobe Community Professional

There are two issues here:

1. Some older versions of the software will function on Windows 10. If you are taking a poll, I can attest to the fact that PSEv,8 installs and functions normally.

2. After having the results of the theoretical poll, how do you intend to procure prior (old) versions of PSE?

3. Me thinks, with all due respect,  the adaptive response to reality is to purchase the current version of PSE for your modern (WIN10) operating system. 

TOPICS
Windows

Views

60

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

What's the oldest Elements version I can use on Win10

New Here ,
Nov 09, 2020

Copy link to clipboard

Copied

I've used Photoshop 2.0 for Years, up to and including on my Win 7.  Sadly I can't use my Win 7 anymore, and 2.0 won't work on Win 10 (says it need more virtual memory - can I fix that?) .  I don't need fancy, the effects in 2.0 were just fine.  What's the oldest version of Elements I can use with Win 10?  Thanks

Adobe Community Professional
Correct answer by hatstead | Adobe Community Professional

There are two issues here:

1. Some older versions of the software will function on Windows 10. If you are taking a poll, I can attest to the fact that PSEv,8 installs and functions normally.

2. After having the results of the theoretical poll, how do you intend to procure prior (old) versions of PSE?

3. Me thinks, with all due respect,  the adaptive response to reality is to purchase the current version of PSE for your modern (WIN10) operating system. 

TOPICS
Windows

Views

61

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 09, 2020 0
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 0
New Here ,
Nov 13, 2020

Copy link to clipboard

Copied

Thank you Bob, but that leaves me more confused.  Some say 9, some say 15, I find these posts very confusing to follow.  I'm assuming since I don't need any more bells and whistles than 2.0 offered, the oldest that works on Win10 should do it.  Can you give me a simple answer?  Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

There are two issues here:

1. Some older versions of the software will function on Windows 10. If you are taking a poll, I can attest to the fact that PSEv,8 installs and functions normally.

2. After having the results of the theoretical poll, how do you intend to procure prior (old) versions of PSE?

3. Me thinks, with all due respect,  the adaptive response to reality is to purchase the current version of PSE for your modern (WIN10) operating system. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 1
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

Can you give me a simple answer?

If you had read all of the replies in the link I gave you, you would have sene part of the reply by  MichelBParis:

"I have also been able to reinstall versions 6 and 10 without major problems." 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

Can you give me a simple answer?

If you had read all of the replies in the link I gave you, you would have sene part of the reply by  MichelBParis:

"I have also been able to reinstall versions 6 and 10 without major problems." 

 

Yes, Peru Bob,

That's still true today for me and I even think it would be true for PSE2. However, many users will not be able to do it because of mising DLLs they don't know how to install, compatibility settings in the OS or limitations in the size of the install drive to be compatible with the very old software.

 

So, I totally agree with hatstead. Being able to re-install an old version is more than problematic. Support from Adobe is limited to the current and immediately old version, and how many other users in the community can help with versions older than PSE11 ?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
Peru Bob LATEST
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

PSE 5 won't run properly on Windows 10, so  I doubt PSE 2 would.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0