MAC laptop not meeting requirements - URGENT HELP NEEDED

New Here ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

I want to download the free trial for the photoshop and it keeps giving me the message that my laptop MAC OS X 10.10.5 is not compatible.

I tried searching in the help tab, as to what is needed. I have enough space in my laptop and i don't know what else is required.

Please help!!

Views

76

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 18, 2018 Feb 18, 2018

Copy link to clipboard

Copied

LATEST

Photoshop Express is an app for iPad and iPhone only. You need the regular Photoshop forum, though the message is simply true. In the Photoshop forum there is a link to system requirements. Check the Mac OS version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Photoshop Express Creative Edits