Highlighted

PS on iPad Pro totally unusable Thoughts?

New Here ,
Jun 07, 2020

Copy link to clipboard

Copied

PS on my iPad Pro 12 keeps crashing and virtually any actions with pencil or finger require 5-10 seconds take to effect.  

I have an iPAD Pro 12 with 512GB running the latest iPadOS;  the latest PS version, and internet spends over 100MB up/down.  Yet I have considerable issues with any and all PS responses.  I have frequent crashes when trying to delete a layer.  I have removed and re-downloaded PS and have restarted the iPAD several times.  Still...same issues.

What's the problem??   I sure don't have these issues with the other Adobe iPAD apps or the slew of other art/graphic programs I use on the iPAD.  Any thoughts?  Thanks!

TOPICS
Crash or freeze, iPad, Problem or error

Views

281

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PS on iPad Pro totally unusable Thoughts?

New Here ,
Jun 07, 2020

Copy link to clipboard

Copied

PS on my iPad Pro 12 keeps crashing and virtually any actions with pencil or finger require 5-10 seconds take to effect.  

I have an iPAD Pro 12 with 512GB running the latest iPadOS;  the latest PS version, and internet spends over 100MB up/down.  Yet I have considerable issues with any and all PS responses.  I have frequent crashes when trying to delete a layer.  I have removed and re-downloaded PS and have restarted the iPAD several times.  Still...same issues.

What's the problem??   I sure don't have these issues with the other Adobe iPAD apps or the slew of other art/graphic programs I use on the iPAD.  Any thoughts?  Thanks!

TOPICS
Crash or freeze, iPad, Problem or error

Views

282

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 07, 2020 0
Adobe Employee ,
Jun 08, 2020

Copy link to clipboard

Copied

Can you be more specific about what you are doing where you hit the performance issues? What size files are you using? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2020 0
New Here ,
Jun 12, 2020

Copy link to clipboard

Copied

Thanks for your response.  My files are super small as I have only 2-3 layers with not much (if anything) on any layer,  since I can't get very far in the app.  A few times I have added 5-6 empty layers inadvertent, since the app is so slow I see no action for awhile.  The performance issues actually begin when 1st opening the app.  For example,  it takes awhile to create a new document...just standard iPad size.  Same bad latency with opening a basic image. Once in the app,  adding any layers takes awhile,  and selecting any brushes takes 10-15 seconds or more...really!  Soon,  performing any action just freezes the app and/or it crashes.  Not sure what's going on here as I have a robust iPad Pro with lots of memory,  etc.  Not sure if relevant, but I have installed 3,425 fonts on this iPad; however, no other app other than PS exhibits these performance issues.   

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Adobe Employee ,
Jun 12, 2020

Copy link to clipboard

Copied

Hello, and thanks for the additional information. I have not seen that kind of performance degredation on my device, but I do not have such a large amount of fonts installed. I will investigate further. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
New Here ,
Jun 13, 2020

Copy link to clipboard

Copied

Thanks!  I see that when opening "help" and clicking on any of the hot links...nothing happens.  I had to close hello then reopen it to have either my pencil or finger activate the community link.  Took a few tries.  So performance issues do begin right on the onset of opening the app.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2020 0
Adobe Employee ,
Jun 15, 2020

Copy link to clipboard

Copied

Hello! Thanks for providing so much information. I have a couple questions, so I can work on isolating your problem.

Are the fonts loaded locally on the device, or are you using Adobe Fonts download? If you are using the fonts locally, what app are you using to load the fonts onto the device? 

Also, are you running the device over wifi or 4G? 

Thank you. I really appreciate the time you are putting into helping us rectify this problem.

-Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2020 0
New Here ,
Jun 16, 2020

Copy link to clipboard

Copied

Hello.

 

After the recent 1.5 update,  seems to work a little faster...I get further.  However,  I still have some crashes after adding a few layers (blank layers).  Also,  still have latency but I can actually pick 2-3 brushes.  Any more than 2-3 layers (plain-no content) seems to really slow the program down.  Deleting a layer takes 6-10 seconds to take affect.

I mostly use iFONT to install fonts (which I acquire/get from various online sources,  incl MyFonts, Scriptorium, LinoType, CreativeMarket, and various other paid and free sites).  I am not using Adobe Fonts download (actually,  I've never used Adobe Fonts download...maybe I'll check it out).  

 

Just using regular WiFi,  5G not available yet where I live (TampaBay).

 

Thanks for your help!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2020 0
Adobe Employee ,
Jun 23, 2020

Copy link to clipboard

Copied

Quick note - thank you for the details on how you are loading fonts. I am still working on isolating this. I will let you know when I have some detailed info. Appreciate your time!

-Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 0
New Here ,
Jul 04, 2020

Copy link to clipboard

Copied

Thanks again for your help.  PS froze again just with adding 3 layers (all we're empty to test).  Each layer took about 8-10 seconds to add (to be added).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 04, 2020 0