After installing macOS Big Sur 11.4 Photoshop freezes a few seconds in

Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hi,

I updated my MacBook Pro (M1 16GB 2020) recently to macOS Big Sur 11.4, but ever since then it would freeze a few seconds after I start working (using the paintbrush) and I would have to force close the program, but reopening it afterwards just repeats the freeze. I've tried restarting the computer but it doesn't solve the issue. 

It never used to do this on my old OS. I also tried to give Photoshop access rights in Preferences > Security and Privacy > Accessibility + Full Disc Access but that only worked temporarily and now it's back to freezing again after a few seconds. 

Please, please help, I'm at my wit's end not being able to work on anything at all. Sent maybe two crash reports to you guys!

Thank you so much!

TOPICS
Crash or freeze

Views

2.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

What version of Photoshop are you running?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks! I'm using 22.4.1 on Creative Cloud, pretty sure it's up to date!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Are you running it in native mode or Rosetta 2?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Thanks, checked and I'm definitely running it in native mode! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Try trashing your Photoshop preferences. Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) immediately after launching Photoshop. You will be prompted to delete the current settings.

(Mac OS only) Open the Preferences folder in the Library folder*, and drag the Adobe Photoshop CS Settings folder to the Trash.

This action only affects the items found in the preferences dialog box. Numerous program settings are stored in the Adobe Photoshop Preferences file, including general display options, file-saving options, performance options, cursor options, transparency options, type options, and options for plug‑ins and scratch disks. Brushes (and lots of other setting) are not affected by the above instructions for deleting preferences. You may wish to make a screen capture of the settings in the Preferences dialog to reset them prior to deleting of this file.

Also: https://helpx.adobe.com/photoshop/using/preferences.html

*To manually delete Photoshop preferences:
Quit Photoshop.
Navigate to Photoshop's Preferences folder:
macOS: Users/[user name]/Library/Preferences/Adobe Photoshop [version] Settings
Windows 10: Users/[user name]/AppData/Roaming/Adobe/Adobe Photoshop [version]/Adobe Photoshop [version] Settings

Note:
The user Library folder is hidden by default on macOS. To access files in the hidden user Library folder, see How to access hidden user library files.
Drag the entire Adobe Photoshop [Version] Settings folder to the desktop or somewhere safe for a back-up of your settings 

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Thanks for the help! I reset my preferences but it still freezes... not sure what to do next.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

It appears that some people get going again with the preferences fix.  It didn't work for me.  Neither did clean uninstall and reinstall.  I just got off chat with the 2nd tier support.  It looks like the issue is something to do with the graphics card.  Their answer is to use download and use Photoshop 2020. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Pay particular attention to Photoshop's new GPU requirements. See links below.
- https://helpx.adobe.com/photoshop/system-requirements.html
- https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

For what it's worth, I'm still using an older version of PS CC without any stability issues mainly because my GPU card is too old.

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Just checked, I do think my computer meets all the GPU reqs + just bought it this year so it shouldn't be that... thanks for the links I will check the rest of the reqs to see!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

An M1 Mac well exceeds the requirements.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Thanks! I'll try the preferences thing now but pretty sure it's not the graphics card, might roll back to an older version anyway because this one has already been super buggy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

the latest PS builds are meant to run natively on M1 Macs. You'll have issues if you try to run them in Rosetta. That could be why earlier versions worked - they had to run in Rosetta. The new ones dont.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

In case this helps someone. ....  I've been thinking about the Adobe chat session where I was told that the problem was my graphics card not having enough memory.  If that is the problem, then why did PS 2021 work just fine before the OS 11.4 update and also works under Big Sur when I create a new user with admin access.  There must be something else that is causing this conflict.  (today's new update didn't help).  I'm going back to Apple and have them help me move all my software preferences over to the new user account to see if this will get me back working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Try going to PS Preferences/Technology Preview and check "disable native canvas."

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Thanks, Kevin.  I was able to quickly get to the point of checking the box beside deactivate native canvas but PS hangs (becomes unresponsive) before it can be enabled.  Any ideas on how I could make this happen without launching Photoshop?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Try two things: 

First reset your prefs - hold Shift+Ctrl+Opt+Cmd when you launch before the splash screen appears. 

It will ask to confirm. 

If that doesnt work restart PS holding shift key down to disable plugins it will confirm that too. 

Hopefully one way or the other will get you in long enough to edit your prefs. 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Can you double check your PS access in the System Security Prefs? If it was updated it might need to be removed and readded. Also make sure it is checked on and not just in the list.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Yup it's all checked on in Security preferences (accessibility/full disc), I added PS in very recently to try fix the issue but it didn't seem to work for long;;;

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Sounds silly but I'd remove it from the list and readd. See if it resolves. 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Having all the same issues, on a non-M1 2020 MacBook Pro w/ MacOS 11.4.

I just downgraded to 22.2.0, and everything works fine. So something went awry in one of these more recent PS updates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Thanks for the help, I tried rolling back to that ver as well and same issue... crying

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

When you uninstall you may need to run the CC Cleaner tool to remove any system resources first. 

https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I did this and then Adobe did it.  Unfortunately it didn't help.  Thanks for the suggestion though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

George - in the process of fixing this, I did do a lot of different things. I ran the CC Cleaner as Kevin suggested. I also deleted all my Preferences files. Was sure to take some steps as Root ('sudo...' from command line). Uninstalled everything. Reinstalled. Probably could not recreate an audit path of every step I took.  But eventually 22.2.0 did the trick for me. I have a fairly common set of Apps on my MacBook Pro. I don't think I've got anything particularly crazy running on my machine. JR

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines