All Menu Items Greyed Out CS5

Community Beginner ,
May 12, 2010

Copy link to clipboard

Copied

Everytime I use Photoshop CS5, at some point all of the menu items get greyed out and don't come back unless I quit and reopen Photoshop.  There doesn't seem to be anything that triggers it.

All the keyboard shortcut and the mouse and tools work fine, but I can't select any of the menu items in the dropdowns in the menu bar (Photoshop, File, Edit, Image, etc)

This is obviously very annoying...any ideas?

Views

25.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
May 12, 2010

Copy link to clipboard

Copied

Did you try trashing your preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 12, 2010

Copy link to clipboard

Copied

I'll give that a try and see if it happens again.  Unfortunately since I haven't figured out when it happens I don't know how to replicate the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
May 13, 2010

Copy link to clipboard

Copied

I bumped into this little beauty today. Every item in every menu greyed out.

"Trash your Prefs" parrots steer clear. It aint prefs. I'll tell you what it is, though: scary. Quitting the file without saving and reopening cleared it. I couldn't begin to guess what set it off.

Hey Chris....5000 beta testers and we're the only two to see this? I doubt it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 13, 2010

Copy link to clipboard

Copied

same problem. no apparent reason. trashing prefs did nothing. very uncool


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 13, 2010

Copy link to clipboard

Copied

I've had my different workspace shortcuts grayed out when they shouldn't be, but not all menu items.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2010

Copy link to clipboard

Copied

Re: Frank;   yeah, only a few (2 or 3) reports.

Do you have any third party plugins installed?  If so, have you tried disabling them?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
May 13, 2010

Copy link to clipboard

Copied

No, Chris. Not one 3rd party plug-in. This is a 2 day old clean install of CS5 Creative Suite Premium (the installation of which, went flawlessly). The only divergence from the stock Photoshop install is the use of some CS4 preset files: Actions, Gradients, Shapes and Swatches...which were copied over from 4 to 5's Preset folders.

I was running in 64bit mode. Primary scratch disk is a dedicated empty internal 1/2tb drive. The file used at the time was about 8mb and uses about 50 layers tucked into 7-8 Groups.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2010

Copy link to clipboard

Copied

OK, plugins would have been too easy.

Are you sure you aren't in a modal state (like with a dialog off the main display)?

The next things to look at are system modifications (we've already seen 2 that conflict with Photoshop's new Cocoa code), and drivers (especially any that might have per-app preferences).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 14, 2010

Copy link to clipboard

Copied

I'm getting the same issue over here...

Running PS CS5 on a 8core MacPro with 9gb RAM...

PS runs in 64bit

MAC OS X 10.5.8 installed

The problem appears from time to time...without specific reasons...

I am sure I'm not in any modal state cause all tools and keyboard shortcuts still work perfectly... only the menu gets grayed out.

I don't really know what Chris Cox means by "system modifications"... can you tell us a bit more about this ?

Also note that this is one of the many problems we have with CS5...  You probably have heard of trouble with panning and troubles with the liquify tool beeing incredibly slow...  I know it has nothing to do with the problem discussed in this thread... but I'm wondering is it couldn't somehow be all related...

... so far, PS CS5 is a pain in the ***, but I'm getting this feeling that it's a matter of a few fixes to get it up and running smoothly.

Thanks.

J.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 14, 2010

Copy link to clipboard

Copied

After trashing my preferences file I haven't run into the problem again, but as I said before I'm not sure what I can do to replicate the problem because it seemed random.  As far as system modifications, I haven't made any mods to my MBP.  It is a stock i7 15 inch.  I also installed CS5 from scratch and didn't bring in anything from CS4.  I decided to start clean.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2010

Copy link to clipboard

Copied

I don't really know what Chris Cox means by "system modifications"... can you tell us a bit more about this ?

Things you added to modify menu behavior, add new behavior, add new color pickers, etc. to the OS.

We know about the Liquify problem.

Panning is still being looked into (but we can't even get consistent descriptions of the problem...).

We have no idea (other than third party plugins, or a modal dialog) why the menus would be grayed out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 14, 2010

Copy link to clipboard

Copied

Well... can't think of any modifications I would have made...

One thing I didn't mention but that pops to my mind now :  The computer runs 3 screens, with 2 video cards installed (a nVidia 8800GT as the main display (2 screens) and a ati Radeon HD 2600XT for the 3rd screen)  That used to be a problem for CS4, which was unable to use the openGL of the nVidia...  OpenGL is now working in CS5...   Now, I guess this has nothing to do with it... but thought I should mention it.

Also... I'm wondering... is there anything we should do if the grayed out menu problem should arise again ?  I'm thinking debug info that we could somehow get to you...

Thanks

J.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
May 15, 2010

Copy link to clipboard

Copied

Chris:

No modal menus were up from anything else (or PS itself).  I just went to save a file and found that greyness abounded. Straight 10.6.3 install, no extras.

If this helps, I am running two ACD's 30" and 24 into an Apple supplied X1900XT card. There was nothing I could do to document this beyond grabbing a screen shot of one of the greyed menu pulldowns.

I worked with it for about 9 hours today and haven't seen it.

I should mention that because nothing was available from the menus, I treated it as though it were a hang/crash. I didn't attempt to try a CMD/S to save the doc I was working on out of potential corrupt file paranoia. Figured it was safer to force quit, shut down, reboot and relaunch. Didn't see it after that either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 23, 2010

Copy link to clipboard

Copied

The same issue here. I have had it twice now in Photoshop.. no idea why. No plugins, no extras, all the preferences untouched. All other keyboard shortcuts working but the program it self won't quit with cmd+Q.

Lucky us the shortcuts work and we don't loose any files!

Late 2008 MBP (Core2Duo), 4Gt, OS X 10.5.8, PS runs in 64bit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 24, 2010

Copy link to clipboard

Copied

None of the items on 3D work. All gray.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2010

Copy link to clipboard

Copied

Duck - that's a completely different problem.  The 3D features require OpenGL, if you don't have a video card that meets the requirements, the 3D commands won't be available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 24, 2010

Copy link to clipboard

Copied

You are right. I finally got the problem solved with an Adobe professional, after a long hold. We have all had these problems, yes. The program wasn't reading my card. I exited the program. Shut off the GL whatever. Rebooted and turned it on. It said, glad to see you Mr. NVidia. Now you can do #D.

Thanks for the help.

duckshots@comcast.net

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 25, 2010

Copy link to clipboard

Copied

Not working again. I have an Nvidia card that should work fine. Don't understand.

Duck

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 04, 2010

Copy link to clipboard

Copied

Add another one to the pile. Nvidia GTX 285 with 2 monitors, one being a 30" Cinema Display.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 04, 2010

Copy link to clipboard

Copied

Same issue here. I'm on a Mac Pro Dual Quad 2.8ghz Xeon, 6GB RAM, os X 10.5.8. I can save with command-S but all menu items grayed out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 05, 2010

Copy link to clipboard

Copied

So what do we do? I have contacted Adobe support a few times. It works for a click and then gray again.

Thanks for the reply!

duckshots@comcast.net

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2010

Copy link to clipboard

Copied

At least one person reported that the cause was a third party plugin - remove the plugin, problem goes away.

Another had font issues, and clearing the Apple font cache made the problem go away.

Yet another had corrupt fonts: validating them in FontBook, then removing the corrupt fonts made the problem go away.

But we haven't been able to reproduce the problem reliably enough to debug it.  (last time I got it, #$%^@%#$% GDB crashed when I tried to attach)

And we suspect that there is some underlying issue with event handling that makes the grayed out menus occur (because when it happens, normal keyboard shortcut handling is messed up in addition to grayed out fonts).

We're still actively investigating this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Jun 06, 2010

Copy link to clipboard

Copied

I've had this happen a couple of times in my two weeks of using Photoshpp CS5. It looks like some OS inconsistency to me. The solution is simply to go into the Finder and activate a Window, then back to Photoshop. You'll find that the menus and windows come back, no need to quit Photoshop. Again further evidence that OSX 10.6 is not ready for prime time. No plug ins - Just photoshop installed clean and simple.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 07, 2010

Copy link to clipboard

Copied

I tried it but it didn't work. I will try again.

Thanks.

duckshots@comcast.net

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 10, 2010

Copy link to clipboard

Copied

I'm having this problem as well. After having CS4 crash constantly on my macbook, I was happy to get into CS5, but now I am havng the menus ALL greyed out. I think I notice it happening mostly after I command+S (to save my work) but I will pay attention in the future to see if anything else specifically triggers it.

The only fix is completely shutting down CS5 and reopening. This will become a hassle.

Has there been any news of what this is or if a fix will be available.

I am using OS 10.5.8 Leopard on a macbook

No plug-ins. No modifications. No imports from CS4

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2010

Copy link to clipboard

Copied

Has there been any news of what this is or if a fix will be available.

It's an event problem in Cocoa.  We're really not sure what triggers it, and we can't reproduce it reliably to debug it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 11, 2010

Copy link to clipboard

Copied

Command + S did it. I resized canvas (resize was done from the menus so they were working OK) and saved with command + S. Then clicked to next document in different window and wanted to resize canvas with that one too. All the menus were gray.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jun 11, 2010

Copy link to clipboard

Copied

Hi

Just to add that it occurred the first, or second time, I booted PhotoShop CS5 on a new i7 10.6.3 machine. All menus without exception were greyed. I discovered it trying Cmd O which didn't work. After a moment being stunned, then stumped, I just instinctively hit the Cmd Q as a last ditch before reaching for the force quit in the Apple menu and was surprised to find it  responded to that keyboard command and quit. Since then (and so far) it's been fine.

I'm desparately trying to think which other app in the Premium Suite did it on first boot too. I think it was Illustrator though I cannot be certain. By then I'd seen it before and dismissed it as "oh that again". The same applied - Cmd Q and reboot = been fine since.

I had installed CS4 on the same brand new machine (no migration so I  know it was a 'clean' machine) just the month before. The CS5 suite was an upgrade as opposed to a new install. I'd not done anything to customise PhotoShop CS4 during the month, as I knew I'd be getting the upgrade and my work was mostly in the other apps.

The other apps in the Premium Suite haven't done this particular party trick to me... yet.

Whether this tells anyone anything, or helps point the way to the 'cocoa event', I don't know, but I thought I'd add my experience just incase it does help. Is there anywhere where this might be recorded? I'm pretty confident with the Mac and happy to supply info.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2010

Copy link to clipboard

Copied

We think we found the smoking gun for this problem just yesterday (the progress bar).

We're working on it now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 16, 2010

Copy link to clipboard

Copied

Any updates on this? I have the same issue on 2 different os x machines and its killing me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 16, 2010

Copy link to clipboard

Copied

It's close. We're in the final stages of testing the update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 16, 2010

Copy link to clipboard

Copied

Great to hear!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 25, 2010

Copy link to clipboard

Copied

Just a quick question:

Will the update just be a part of the regular adobe updates that become available to our software, or will we have to specifically download a patch?


Sidenotes: I am noticing that it is just happening occasionally after a cmnd+S typically in larger documents. I am happy that I am still able to save my work before restarting CS5 so I don't lose anything, but I will be thrilled with an update that patches this little nuisance. It doesn't happen ALL the time, but it happens enough!!

Thank you for the feedback and working on the problem!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 25, 2010

Copy link to clipboard

Copied

It will become available as part of the regular updater. Photoshop will give you a notification that an update is available, or you will be able to get it by choosing Help>Updates once it becomes available.

You are describing exactly how it happens. The Save progress dialog on large files/slow drives triggers it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 10, 2010

Copy link to clipboard

Copied

I have a very specific version of this problem.  Sometimes, especially after I expand my canvas to add a white border that I then want to stroke, I'm unable to select all, either with a keyboard shortcut or with the menu.  When I pull down the menu, the select all command is not available.  If I back up, before expanding my canvas, I am able to select all and stroke.  I am not in a mode that should prevent me from doing this, and have a normal layer as my active one.  I've been using PS for enough years to know that this is not the normal behavior.  After a restart, it is sometimes fine.  Occasionally, a second restart is required to fix the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 10, 2010

Copy link to clipboard

Copied

Glad I am not the only one, because then it would be me and not the program.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 01, 2010

Copy link to clipboard

Copied

I get the same problem on Windows Professional x64 using Adobe Photoshop 64bit

I have 8GB of Ram and 512MB Nvidia 8800GTS Video Card. 

I noticed the problem 1st when 3D menu would come and go as I went into Photoshop a few times..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2010

Copy link to clipboard

Copied

This is the Macintosh forum, and the menus graying out was a Macintosh specific bug.

So I doubt you have the same problem.

The 3D menu can be grayed out because your video card driver isn't capable of using the 3D features (can be intermittent if it returns errors).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 01, 2010

Copy link to clipboard

Copied

I know it is a Mac Forum but I figured I'd let you know that it is occurring across the board,  oddly enough it works fine using the 32bit version and not the 64bit version of Photoshop.  3D works sometimes and doesn't the next..comes and goes time to time really random haven't got a clue.


I updated my drivers for my card, and got the latest updates from Adobe same problem.  I even tried restarting, deleting my preferences and nothing had any effect.

I even attached a link to a video of me having this problem so you can see for yourself there is something going on that is really wrong.

  • I am originally in Photoshop 32bit (You can see the 3D Menu on the top + in the performance it recognizes the Card)
  • Then I go into CS5 Adobe Photoshop 64Bit (You do not see the Video card being detected)  <-- That may be an issue
  • Then I go back to 32bit to show I'm not kidding

Here is the video:

http://www.computerrich.com/downloads/Problem_with_64Bit_Photoshop.swf

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...