Highlighted

Alt key activate menu bar in Photoshop

Community Beginner ,
Dec 27, 2016

Copy link to clipboard

Copied

Hi

I have an issue that is driving me crazy since I switched to Windows (now win10). When i press the alt key, using the lens or the stamp for example, the menu bar get activated and starts to open menus, or beeping! Moreover if the menu bar is activated when I press a shortcut key to change instrument i get the result of choosing a menu line!

I have this problem with every photoshop version, included the 2017

Is there a way to stop this behavior on Windows10?

Thanks

Since i dont use arrow keys when ALT key is pressed I dont bother it at all, but I just do quick research and found something like that in the web:

  1. Create a new text file (txt, not word) and rename it with a *.ahk extension (eg: noAlt.ahk)
  2. Right click on the *.ahk file and 'Edit'
  3. Copy and paste into document: ~LAlt Up:: return
  4. Save, then right click on file and select, "Compile Script"

An exe with the same name as your file (eg: notAlt.exe) should be created in the same directory.

  1. Run the *.exe, which will appear in the notification area.
  2. Profit!

( Note: The script must be running in the background to work. You might consider setting it as a startup item, or copying to the startup folder. )

That should work, but honestly didn't try yet.

Views

11.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Alt key activate menu bar in Photoshop

Community Beginner ,
Dec 27, 2016

Copy link to clipboard

Copied

Hi

I have an issue that is driving me crazy since I switched to Windows (now win10). When i press the alt key, using the lens or the stamp for example, the menu bar get activated and starts to open menus, or beeping! Moreover if the menu bar is activated when I press a shortcut key to change instrument i get the result of choosing a menu line!

I have this problem with every photoshop version, included the 2017

Is there a way to stop this behavior on Windows10?

Thanks

Since i dont use arrow keys when ALT key is pressed I dont bother it at all, but I just do quick research and found something like that in the web:

  1. Create a new text file (txt, not word) and rename it with a *.ahk extension (eg: noAlt.ahk)
  2. Right click on the *.ahk file and 'Edit'
  3. Copy and paste into document: ~LAlt Up:: return
  4. Save, then right click on file and select, "Compile Script"

An exe with the same name as your file (eg: notAlt.exe) should be created in the same directory.

  1. Run the *.exe, which will appear in the notification area.
  2. Profit!

( Note: The script must be running in the background to work. You might consider setting it as a startup item, or copying to the startup folder. )

That should work, but honestly didn't try yet.

Views

11.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 27, 2016 0
Contributor ,
Dec 27, 2016

Copy link to clipboard

Copied

It's the behavior of Windows since i suppose about version 98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2016 0
Community Beginner ,
Dec 28, 2016

Copy link to clipboard

Copied

Thaks MBorowiec, but I also use a lot Cinema 4D for example and it doesn't have this problem at all. I think Adobe should fix it if It's a known problem since many Windows versions, don't you?

Do you know if there is a way to disable completely this behavior in the whole system?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2016 0
Contributor ,
Dec 28, 2016

Copy link to clipboard

Copied

Since i dont use arrow keys when ALT key is pressed I dont bother it at all, but I just do quick research and found something like that in the web:

  1. Create a new text file (txt, not word) and rename it with a *.ahk extension (eg: noAlt.ahk)
  2. Right click on the *.ahk file and 'Edit'
  3. Copy and paste into document: ~LAlt Up:: return
  4. Save, then right click on file and select, "Compile Script"

An exe with the same name as your file (eg: notAlt.exe) should be created in the same directory.

  1. Run the *.exe, which will appear in the notification area.
  2. Profit!

( Note: The script must be running in the background to work. You might consider setting it as a startup item, or copying to the startup folder. )

That should work, but honestly didn't try yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2016 5
Adobe Community Professional ,
Dec 28, 2016

Copy link to clipboard

Copied

LUJA wrote:

Thaks MBorowiec, but I also use a lot Cinema 4D for example and it doesn't have this problem at all. I think Adobe should fix it if It's a known problem since many Windows versions, don't you?

Do you know if there is a way to disable completely this behavior in the whole system?

I don't see what is to "fix".

When using the stamp tool and pressing Alt - yes the menus will be highlighted and one will be selected if you press a letter key, which is standard windows behaviour. However if you don't press a letter key and click with the mouse instead then it selects the area for the source of the clone stamp tool.

I, for one, would not want to see the windows standard way of getting to menus via Alt removed

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2016 0
New Here ,
Nov 21, 2017

Copy link to clipboard

Copied

Thank you very very much! That was a quite annoying function.

I´d like to contribute to this thread by posting a link to a similar script written by Jens Marchewka for those to which it the functionality of "alt + shift" is important (for changing keyboard language, for instance):
Disable the activation of the menu bar when Alt is pressed in Windows 7 - Super User

It works, as expected, in Win 10 as well. Once again, thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2017 1
Community Beginner ,
Dec 06, 2017

Copy link to clipboard

Copied

People who using all CC products as me struggling with that ALT as now new 2017 Premiere Pro still have this Alt in it, at least Adobe could let us have option to Disable/Enable that ALT future/BUG

keyboard shortcuts are speeding my workflow and be unable to use ALT it make key combination long as I simply can't assigned F+ALT !

BTW running scripts in background ugh how many should we have it !!??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2017 0
Community Beginner ,
Mar 04, 2018

Copy link to clipboard

Copied

Hello David,

maybe you should change angle of view und you don´t have worked in this workflows. There is one they use for everything a mouse, and the other one use a shortcut. For Example in the help, there is a shortcut for fill in foreground colors. The shortcut is press alt+backspace. That does not work you have to push 2xtime alt than it works. That has to FIX!

Best Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2018 0
Community Beginner ,
Jan 13, 2019

Copy link to clipboard

Copied

It works, but now editing the layer type locks the scroll wheel - holding alt to zoom out afterwards now just keeps changing the layer mode when before it would zoom.

I'm getting sick of PS, after decades of use. These are everyday things that just don't work but that cause endless headaches. This is just one of many.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 13, 2019 0
Community Beginner ,
Dec 30, 2016

Copy link to clipboard

Copied

MBorowiec

The script is running, I see it in the activity manager but the menu selection is still working

davescm

There are many occasion to press the alt key. The problem is that many times the menu maintains the selection even after releasing the alt key so the next button you press causes a selection inside the menu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2016 1
Community Beginner ,
Jan 03, 2017

Copy link to clipboard

Copied

Upgrade:

When I star Photoshop with the running script the menu is highlighted only while keeping the alt key pressed. Without script the menu remains highlighted even after the release of the alt key causing the involuntary selection of Items inside when an other letter key is pressed. I think this should solve the problem 99%. I test for a few days!

Many thanks and happy New Year!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2017 0
New Here ,
Dec 01, 2017

Copy link to clipboard

Copied

Im having the same problem, and, browsing around, I see a ton of people asking the same question going back 7 years.  My question is, what would it take to get Adobe developers to fix this on their end?

If a significant portion of their users need a third party workaround to fix a stupid hotkey problem, how can we get them to fix it?  Photoshop is so good on hotkey customization in every other regard, it's weird that this one thing is still an issue. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 1
New Here ,
Feb 06, 2018

Copy link to clipboard

Copied

I don't have a solution for avoiding the activation of the menu bar, but if you want to shut off the beep, and are ok with making changes to your Window's settings then you can do the following:

  1. Go to Control Panel > Hardware and Sound > Sound
  2. Click on the Sounds Tab, and in the Program Events box find Windows > Default Beep
  3. Click on Default Beep and in the lower Sounds drop-down switch "Windows Background" to "None"

While the menu activation issue is annoying, I generally just click on the canvas after zooming around in order to gain back access to the hotkeys. It avoids having to reach over for 'Esc' every time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 1
Community Beginner ,
Mar 04, 2018

Copy link to clipboard

Copied

my Workflow for this stupid adobe issue is to push fast two times alt.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2018 1