Apple M1 - Graphics processor issue when undocked from monitor

New Here ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

Hi everyone -

 

I have a weird issue that seems to be impacting my new M1 MacBook Pro. Photoshop only seems to function properly with the graphics processor enabled when using it on an external display. Until today, this is the only way I had used it (external display with lid closed), but some troubleshooting has shown some odd behavior when attempting to run it on my Macbook's display.

 

The issue

  • When attempting to use Photoshop undocked with graphics processor enabled, opening a new document or existing photo displays a black screen within the workable area for that document/image. Interacting within this space (drawing, moving, flood fill, creating a gradient, etc) causes this space to flicker and then go black again.
  • If I leave graphics processor enabled and connect to an external monitor, Photoshop works fine when I'm using it on the external monitor. An interesting note: if I connect to a 2nd monitor and keep my Macbook open, I can only use Photoshop without issues if it's running on the external monitor. Dragging Photoshop to my Macbook's display still has the same issue as above.
  • Of course, disabling graphics processor fixes the issue on my Macbook's display, but I'd like to be able to use all the bells and whistles of this new device.

 

System Information

  • Device: MacBook Pro M1
  • OS: Big Sur 11.4
  • Photoshop: 22.4.1

 

Has anyone come across this strangely specific behavior before, and come across a fix for it? I'd like to avoid having to disable graphics processing whenever I use Photoshop undocked, and don't want to miss out on using the full suite of features. I know M1 is relatively new, and perhaps this is a bug that will eventually get worked out - but thought I'd drop in and see if anyone has any advice.

 

Thanks so much!

TOPICS
Mac, Problem or error

Views

285

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

LATEST

Go to preferences Tech preview and check "Deactivate Native Canvas". 

Restart Photoshop. 

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines