Batch action for a generic filename

Community Beginner ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I have a bunch of images in a folder linked with multiple InDesign files and would like to save them in a smaller quality PNG file. The thing is I don't want them to lose their link, so I need them to be overwritten and to keep the same dimensions (so the image doesn't change its size when relinked).

 

I have tried to use Image Process Pro, but the images actually got larger than before when saving for Web and with different PNG settings. The only way I actually managed to make them smaller was to "Save as" and to overwrite the file chosing the "smallest file size (slowerst saving)" option. The images are already pretty small, ranging drom 8kb to 60kb, but the file I'm working is massive and has lots of repetitive images, so any reduction helps not only to improve the indd file performance but also to lower the exported PDF file size.

 

So I performed these exact steps as an action, but for some reason the files are saved as a copy. I'm not very used to work with actions in Photoshop, so might be doing some rookie mistake. Below is the image with my settings for the action:

 

GabrielS_131022_0-1615912305483.png

 

Looks like the whole problem is the "With Copy" part, but I can't get rid of it. If I'm able to overwrite the files that's it, just need to make a batch change in the folder.

 

Any idea on how to solve this? Any tip of alternative is very welcome.

 

Thanks!

TOPICS
Actions and scripting, How to

Views

108

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 16, 2021 Mar 16, 2021
To get rid of Copy in action step uncheck As a Copy option when saving or flaten file before saving and of course check that As a Copy is unchecked.

Likes

Translate

Translate
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

To get rid of Copy in action step uncheck As a Copy option when saving or flaten file before saving and of course check that As a Copy is unchecked.

save as copy.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Yeah, rookie mistake indeed... 

 

Thanks very much, Bojan!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

You are very welcome!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

You may also wish to do a save as in InDesign as it will optimise the file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

LATEST

Yes! Good recall, discovered this not too long ago... Reduces significantly de file size

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines