Highlighted

Block Eraser "stuttering" ...?

Community Beginner ,
Feb 27, 2020

Copy link to clipboard

Copied

So, I've been having issues with my Eraser tool since I got Photoshop CC (Mac), and I can't seem to figure out what the problem is.  Specifically, the issue is with using the Eraser in Block mode.

 

In theory, Block mode should just erase a big square chunk based on the size of the zoom.  No problem, I used to use it all the time back before this whole 'subscription' model thing.   But since getting CC, I seem to be having issues with it 'stuttering' when I drag the Block Eraser tool across the area I need erased.

 

See the attached image: the sweep on the left is what i get from Block Eraser mode, while the other two are in pencil and brush eraser modes (all lines being dragged with the same speed and direction).  Despite that, only the Block Eraser tool is acting up and "stuttering" as it moves.  I don't use a tablet or anything (plain old unfancy mouse), I have already tried resetting the Eraser tool, etc., and every setting I can find for Block Eraser is set to just provide a simple sweep of erased material.  No blurring, no pressure, nothing.  The stuttering is semi-random, in that it seems to change a little as I move (some spots are good, other times it's almost none chosen -- even the initial mouse presss to start sometimes doesn't eras anything until i've moved quite a bit and it kicks in it fits and stutters), so it's not snapping to anything (I have all those turned off, etc.).

 

Any ideas?  I don't use PS for anything super fancy, so Block Eraser was one of my most commonly-used tools, but it's largely uselesss now.

 

In what may be a possible related issue (or not, I dunno), I noticed that the Pencil Eraser doesn't seem to actually erase out to the full size, either (as seen in the screenshot image which I took with the pencil eraser outline for reference around the circle it actually deleted).

 

Thanks in advance!  Any help would be appreciated.

 

erasorproblem.jpg

Topics

Mac, Performance, Problem or error

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Block Eraser "stuttering" ...?

Community Beginner ,
Feb 27, 2020

Copy link to clipboard

Copied

So, I've been having issues with my Eraser tool since I got Photoshop CC (Mac), and I can't seem to figure out what the problem is.  Specifically, the issue is with using the Eraser in Block mode.

 

In theory, Block mode should just erase a big square chunk based on the size of the zoom.  No problem, I used to use it all the time back before this whole 'subscription' model thing.   But since getting CC, I seem to be having issues with it 'stuttering' when I drag the Block Eraser tool across the area I need erased.

 

See the attached image: the sweep on the left is what i get from Block Eraser mode, while the other two are in pencil and brush eraser modes (all lines being dragged with the same speed and direction).  Despite that, only the Block Eraser tool is acting up and "stuttering" as it moves.  I don't use a tablet or anything (plain old unfancy mouse), I have already tried resetting the Eraser tool, etc., and every setting I can find for Block Eraser is set to just provide a simple sweep of erased material.  No blurring, no pressure, nothing.  The stuttering is semi-random, in that it seems to change a little as I move (some spots are good, other times it's almost none chosen -- even the initial mouse presss to start sometimes doesn't eras anything until i've moved quite a bit and it kicks in it fits and stutters), so it's not snapping to anything (I have all those turned off, etc.).

 

Any ideas?  I don't use PS for anything super fancy, so Block Eraser was one of my most commonly-used tools, but it's largely uselesss now.

 

In what may be a possible related issue (or not, I dunno), I noticed that the Pencil Eraser doesn't seem to actually erase out to the full size, either (as seen in the screenshot image which I took with the pencil eraser outline for reference around the circle it actually deleted).

 

Thanks in advance!  Any help would be appreciated.

 

erasorproblem.jpg

Topics

Mac, Performance, Problem or error

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Whit_G_ LATEST
Explorer ,
Jul 21, 2020

Copy link to clipboard

Copied

Yep, same. 😑

 

I've been using this app for over two decades and expect the "old school" tools to work the way they always have. It's stunning and infuriating to (my use case is a tad different) zoom way into a doc in order to carefully knock out pixels one at a time, and the block eraser doesn't just... erase! That's all this tool is supposed to do — you touch a pixel, it's gone, simple as that.

 

But instead, it's behaving as though Spacing or Flow are turned on, neither of which have anything to do with this tool (they are literally not even options, for good reason). I'm having to move the eraser around inside of pixels multiple times to make them disappear, it feels like trying to pick up a drinking glass when you've lost control of your hand. 

 

Please fix this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...