Blocks of some layers disappear after exporting

New Here ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

So sometimes, not all the time, when I export a drawing, random squares of some of the layers will disappear. It's not because of the selection tool. The image is totally fine until I export it, and I've exported it as a PNG and a JPG and the problem persists. I have no idea how to fix this and need help. In the case of the second drawing, it even lightened the pants and didn't erase the layer at all. Icon March 2021.pngPokemon trainer.png

TOPICS
Problem or error

Views

199

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 11, 2021 Mar 11, 2021
Try the following before exporting. These are not fixes but work-arounds...   1. Flatten the imageDuplicate your file and merge all of the layers.Layer > Flatten Image   2. Create merged duplicateSelect the top most layer in the Layers panel. While holding down the Alt/Option key, merge all of the visible layers. This will create a new layer,Alt/Option + Layer > Merge Visible

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

It sounds like an intermittent problem we saw some time back, when Photoshop introduced a new layer compositing engine. To get around it, there was a checkbox in preferences to "use legacy compositing", which reverted to the old engine.

 

They now claim the problem is fixed, and the checkbox has been removed.

 

So what exact version are you using?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

I'm using version 22.3

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Try reverting to 22.2.

 

Since the 22.3 update was released yesterday, several problems have come up. This could well be one. My theory is that Apple Silicon support had such high priority that a few too many corners were cut this time.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

They now claim the problem is fixed, and the checkbox has been removed.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Try the following before exporting. These are not fixes but work-arounds...

 

1. Flatten the image
Duplicate your file and merge all of the layers.
Layer > Flatten Image

 

2. Create merged duplicate
Select the top most layer in the Layers panel. While holding down the Alt/Option key, merge all of the visible layers. This will create a new layer,
Alt/Option + Layer > Merge Visible

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines