Highlighted

Can anyone help? "DynamicLink" not available attempting to open Mov in Photoshop CS6

Explorer ,
May 16, 2012

Copy link to clipboard

Copied

Can anyone advise where I should go to get help with this? as this is obviously not the right place!

Hi,

Using CS6 Photoshop extended on iMac early 2008 model.....

Processor  2.8 GHz Intel Core 2 Duo

Memory  4 GB 800 MHz DDR2 SDRAM

Graphics  ATI Radeon HD 2600 Pro 256 MB

Software  Mac OS X Lion 10.7.4 (11E53)

I get this message when I try to open a .mov file...

"Could not complete your request because DynamicLink is not available?"

What does this mean does anyone know - my .mov file is about 7MBs.

Am I expecting too much, I'm hoping to import video and export as animated .gif

Thanks,

Topics

Problem or error

Views

216.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can anyone help? "DynamicLink" not available attempting to open Mov in Photoshop CS6

Explorer ,
May 16, 2012

Copy link to clipboard

Copied

Can anyone advise where I should go to get help with this? as this is obviously not the right place!

Hi,

Using CS6 Photoshop extended on iMac early 2008 model.....

Processor  2.8 GHz Intel Core 2 Duo

Memory  4 GB 800 MHz DDR2 SDRAM

Graphics  ATI Radeon HD 2600 Pro 256 MB

Software  Mac OS X Lion 10.7.4 (11E53)

I get this message when I try to open a .mov file...

"Could not complete your request because DynamicLink is not available?"

What does this mean does anyone know - my .mov file is about 7MBs.

Am I expecting too much, I'm hoping to import video and export as animated .gif

Thanks,

Topics

Problem or error

Views

216.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
May 21, 2012

Copy link to clipboard

Copied

I had the message the first day Dynamiclink Media Server is not available on a Windows PC and opened a bug report. The next day when I tried to reproduce the problem again there was no missing Dynamiclink  and Photoshop opened the dicument.

http://forums.adobe.com/message/4402241#4402241

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
May 21, 2012

Copy link to clipboard

Copied

Computer can get glitches.  If you leave yours on forever, try rebooting computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
May 21, 2012

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 12, 2012

Copy link to clipboard

Copied

Hi,

I recieved and replied to your private message with the following:

If not, would you please verify the following:

0. Restart Photoshop and all Adobe applications (yeah, we have to try it), wait 30 seconds before restarting.

1. Ensure virus/security/parental control software hasn't trapped parts of Photoshop, Bridge, Premiere, Lightroom, or any Adobe app using DynamicLinkMediaServer. (Make sure the Adobe apps are added as exceptions if needed.)

2. Ensure you have the latest version of QuickTime

3. Close all Adobe applications - wait more than 30 seconds, then launch Photoshop and try to open the file.

- If unsuccessful, view Task Manager/Processes to verify necessary processes started up when importing video (dynamiclinkmanager.exe, dynamiclinkmediaserver.exe and Adobe QT32 Server.exe)

- If unsuccessful, please capture the full error message text.

4. Close all Adobe apps, wait 30 seconds - launch Bridge and try to open the file.

Did any of those resolve your issue?

Thanks,

Meredith

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 27, 2012

Copy link to clipboard

Copied

How is it that PS6 needs internet connect where CS5 did not??? Why would the server need internet to conect to media already on the system? Is the a place to go to set that connect differently? I don't always have an internet connection. thanks, Uhane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2012

Copy link to clipboard

Copied

Uh, what?  Who said that DynamicLinkServer needed an internet connection?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 28, 2012

Copy link to clipboard

Copied

Honestly, when I first read about this problem I suspected some online influence myself, Chris.

Put yourself mentally in less knowledgeable shoes and ponder what the terms "Link" and "Server" imply (not to mention what the problem going away by itself might mean, per the other thread).

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 28, 2012

Copy link to clipboard

Copied

Despite what the name sounds like, Dynamic Link Media Server is not connecting to the internet nor does it require any remote server.

Thanks,

Meredith

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 28, 2012

Copy link to clipboard

Copied

@ Noel, Merideth, etal,  

••Just want to understand.. How does it not connect to some remote server and if not a server then to what?  CS5 NEVER denied a link connection in this way.  How does it behave differently from CS5 in it's media loading protocols? Help me if my logic is faulty. 

••When I disable the IP filters on peerguardian I can load media through the "dynamic link server" no prob. and when they are enabled I cannot. It is as simple as that for me.

••I am calling adobe today to find out more what up.

••What relation do these "virus/security/parental control software" have to Adobe products? And how can they "trap parts of Photoshop, Bridge..etc" if not via blocked IPs or denied access to a server?

••PeerGuardian only blocks IPs, therefore, adobe was blocked from loading media via an IP and that means a round trip from a remote server somewhere as well. Again help me if my logic is faulty.

•• I folowed you instructions, Merideth as you posted them above and even reinstalled the app 'cause I didnot want to believe that it was the IP blocker, Peerguardian. But I am not able to load media without first disabling the IP blocks first. This was the consistent result.

••I will post again after my call to adobe and let you'all know what up there..  Aloha, Uhane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 28, 2012

Copy link to clipboard

Copied

A server is not necessarily something on the network.

A server is just something outside the application that provides data or a function.

For example:  Bridge is a server process that sends data to Photoshop for the MiniBridge feature.

There is no internet or network involved here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 28, 2012

Copy link to clipboard

Copied

"Application", "data", "function", "process", "feature"...  If you're wondering, that peculiar dialect is known to we insiders as "geek speak". 

And Chris, I mean "geek" in only the most complimentary way, coming from a fellow "geek".

Regarding calling Adobe, uhanepono, you're talking to the folks right at the forefront of Photoshop development here.  Whomever you might reach via telephone would have to consult with Chris and the others here for the straight scoop.

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 28, 2012

Copy link to clipboard

Copied

Thanks much Noel, Chris etal ! I will seek truth among ye. So is there a work-around for the peerguardian blocking cunundrum? Is there an address I need to add to the allow list? How does CS6 differ from CS5 in it's file fetching protocols? Gotta run... back in a bit...Aloha, U

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 28, 2012

Copy link to clipboard

Copied

Hi A little further along. I tried to connect bridge to PS6 without an intereent connection and failed and bridge crashed as it always does when I don't have an internet connection. I would love it if one of you tried the same thing to see if it's just my system config or if you, too, get similar results. I also was unable to open any media into PS6 without internet connect bypassing bridge, getting the same dynamic server fail message. So it fails whether I am routing through bridge or not. Below are screen shots. How can I get the 2 apps to connect to this dynamic server that is not connected to the internet without having to have an internet connection? Aloha, Uhane

these are all the processes running when trying to open media via bridge in PS6 while not connected to the internet and with Peerguardian not running. Where on this list would be the "dynamic server"?

Screen shot 2012-06-28 at 12.38.48 PM.png

Here is the mini bridge in PS6 not loading and just trying to connect without being able to

Screen shot 2012-06-28 at 12.39.11 PM.png

Screen shot 2012-06-28 at 12.49.47 PM.png

Adding an internet connection without peerguardian running. Here are the running processes.

Screen shot 2012-06-28 at 12.47.21 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 28, 2012

Copy link to clipboard

Copied

DLMS (DynamicLinkMediaServer) asks the operating system for an un-used port when it needs to talk to Photoshop. So, no, there is not a specific address to whitelist.

(I've been told that if we ask for a specific address, it would get flagged by virus protection programs because that's how viruses behave.)

The other times DLMS will open/use a port when crossing the 32->64-bit or 32->32 bit boundary, like when going to Quicktime. However, unless you've signed up for the Headlights program, not one byte of info will be transmitted.

Photoshop didn't use DLMS in CS5.

If PeerGuardian won't let you whitelist an application or process, I currently don't have another option other than temporarily disabling PeerGuardian.

Thanks,

Meredith

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 28, 2012

Copy link to clipboard

Copied

Hi Merideth and thanks for your help! This clears up a lot for me! I will try a few workarounds, now that I know where to focus. aloha, a hui hou, Uhane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 28, 2013

Copy link to clipboard

Copied

If anyone can still help.  I have CS6 Extended, was able to open videos in PS up until a few minutes ago.  In fact, was working on one... PS froze - had no choice but to close and reopen PS and now it won't let me open any videos and I get that DynamicLink Media Server mumbo jumbo.  What happened??!!  As well... just before that, if it has any affect at all... I was trying to open a video in Flash and it gave me all those options to convert my mpg video and it had me convert it to FLV of course, but I think it was also linking to the original video?  I dion't know if that suddenly threw a wrench into the whole sysytem?  But suddenly, out of nowhere, my comp froze, i reopened PS and I can no longer open videos.  What's up?!  PLEASE HELP!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
May 28, 2013

Copy link to clipboard

Copied

You probably have an unhappy version of DLMS already launched. Try closing all Adobe apps that might use DLMS (PS, Premiere, AE, Lightroom, Flash). Wait 30+ secconds, then restart PS. Or just restart the whole system. If it still occurs, please repost and include the exact text of the error message.

Thanks,

Meredith

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 28, 2013

Copy link to clipboard

Copied

Thank you.  I did close, shut down and restart but still had the same problem.  Walked away from my computer... happily didn't break anything, rebooted and happy to say, we're back in business...  THANKS!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 18, 2014

Copy link to clipboard

Copied

So, I have been having this same problem also, I have tried rebooting my machine, I even reinstalled all of Adobe Creative Suite 6, and it still either gets hung up while "Reading Video Format" and after a long time I just click cancel and it has an error message that says the "Could not complete your request because the DynamicLink Media Server is not available" or it completely freezes there and I have to end it with the task manager, or it gets past that, on to the next dialogue window, where I get to choose a couple options about the import, and then it freezes after that window.

So is the only known solution so far to just.. wait?

Edit: I might add that last week, on multiple occasions I was able to perform this function flawlessly, there were no problems, and I haven't changed anything on my computer since then.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 07, 2016

Copy link to clipboard

Copied

The ONLY thing I get is when I try to import my AE project into Adobe Media Encoder, it just says " connecting to Dynamic Link server" for a while, then when it ends, it says could not connect to the Dynamic Link server.

Someone please offer me a solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 29, 2014

Copy link to clipboard

Copied

HI I have the same problem, but I solve it following Jonah instruction below.

It also boosted up he startup time of the program.

---------------------------------------------------------------------------

It's a conflict with some Adobe Preference files.

This morning I decided to try pulling out the entire Adobe Preferences folder, User:Preferences:Adobe and just put back Adobe:After Effects, and After Effects CS5 booted perfectly. It boots quickly and I don't even get the dynamiclinkmanager crash that I have been getting.

And I it seems to have created a new folder in my new Adobe folder, the Adobe QT32server:1.0:TraceDatabase.txt and the dynamiclinkmananger:2.0:memorybalancers5.xml was created this time as well. I then quit after effects, and put back all the other preference files into that folder, though not replacing any of the new versions that were created, and once again After Effect boots and works.

So that was the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 25, 2014

Copy link to clipboard

Copied

Hi all,

After having this issue all year, hope the below helps.


You see my C:\ drive is quite small as it's a SSD, so I made Adobe install programs on my E:\ drive too, however this was the main cause for Adobe not to function.


After adjusting the settings to install everything back to my C:\ drive, it fixed my issue above and allowed me to run the 64bit version.

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 09, 2015

Copy link to clipboard

Copied

Hi everyone,

I am experiencing the same problem, after a fresh clean installation of the mastercollection.

Particularly, I would love to solve this for Photoshop, as the very first post initially asked.

Computer Environment:

MacBook Pro Early 2011

Graphics  AMD Radeon HD 6490M 256 MB

Memory  16 GB 1333 MHz DDR3

SSD with 512GB; about 81GB are still free

Software:

Mavericks  OS X 10.9.5

Adobe Mastercollection CS6 Extended, 64bit.

Including the Dynamic Link Media Server Update 1.0.1 are all individual apps up to date as of today, March 9 2015.

Quicktime Player (v.10.3) and

Quicktime Player v.7.6.6

From this discussion, I followed Merediths suggestions under

  • post #17 (the ones that apply to me as a Mac user).
  • I double-checked, if some security or anti-virus-software was responsible – I don't have any.
  • I also tried her suggestions under post #4 however: #4.4 (her last suggestion in that post) but
  • Bridge is not working at all. It launches, but crashes as soon as you see the workspace.
  • Hence, Mini Bridge in Photoshop is also crashing.
  • I do have all codecs for the videos, that I was trying to open, though.
  • It cannot be an issue, that I have not enough RAM.
  • After several other problems with After Effects, Premiere Pro and Media Encoder, which remain partly unsolved, this post starts form a fresh installation of the whole Adobe Suite (count: 8 times). Even used the Cloud Cleaner Tool beforehand and made sure, all presets are from this CS6 version only.
  • The exact error message that I am getting is «Could not complete the Video Frames to Layer Command because the DynamicLink Media Server is not available.»

Other notes:

I am also following this discussion Re: trying to import video"Could not complete your request because it is not the right kind of docum...

which is a newer thread with the same question (but without any solutions).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 25, 2019

Copy link to clipboard

Copied

Hi guys, after extensively reading the comments here and having to dig deeper into this I fiiiinally found the solution on my Mac and I thought I better share it with everyone.

In my case the problem was in the preferences folder of the Dynamic Link itself:

Library - Preferences - Adobe - dynamiclinkmediaserver

I just renamed this folder and restarted photoshop - I'm finally able to open videos again.

Cheers!

Pedro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 11, 2019

Copy link to clipboard

Copied

Hi Pedro, thanks for sharing that you have solved the problem. Could you be a little more specific to follow the steps you used? Beforehand thank you very much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...