Can't open psdc, not compatible with this version

New Here ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

I have several files saved as .psdc but now no one seems to work, I get the "not compatible with this version" error each time. I haven't updated photoshop since I last opened these files, so I really don't understand the problem. I get the same error just with .psd with files I've saved on my laptop and not in the cloud. These files are pretty important so any help would be greatly appreciated

TOPICS
Crash or freeze, FAQ, Import and export, Performance, Problem or error

Views

60

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

What version of Photoshop do you have open? 

 

~ Jane

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

22.1.1

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines