Highlighted

CEP panels / Enabling nodejs and mixed context makes Photoshop panel to not work

Explorer ,
Jul 27, 2020

Copy link to clipboard

Copied

Hello,

 

I'm building a small local server on as Photoshop panel because I need to use Nodejs for some tasks. The problem is that when I try to enable node js and mixed context on the Parameters under CEFCommandLine in the manifest.xml, doesn't seems to work.

 

When I open the extension that is loading the server, somehow it makes flicker the loader in my cursor like if something was loding but doesn't loads node-js, here's my manifest <extension> tag:
 

 

<Extension Id="cnation.server">
			<DispatchInfo>
				<Resources>
					<MainPath>./localServer.html</MainPath>
					<CEFCommandLine>
					<Parameter>--enable-nodejs</Parameter>
					<Parameter>--mixed-context</Parameter>
					</CEFCommandLine>
				</Resources>
				<Lifecycle>
					<AutoVisible>false</AutoVisible>
				</Lifecycle>
				<UI>
					<Type>Custom</Type>
					<Geometry>
							<Size>
								<Height>100</Height>
								<Width>100</Width>
							</Size>
						</Geometry>
					<Icons />
				</UI>
			</DispatchInfo>
		</Extension>

 

If I remove this two lines: the panel works well but I cannot use Nodejs on the browser to call a Nodejs function:

 

<Parameter>--enable-nodejs</Parameter>
					<Parameter>--mixed-context</Parameter>

 


Someone knows what is going on?

I just found the bug on this. Seems that if you have your extension folder name with some characters like "apostrophe" glitches because some parsing in the backend I think. But i removed the apostrophe and now it works perfectly, I had this issue for what, one month? It was driving me crazy!!

TOPICS
Actions and scripting, Bug, How to, Problem or error

Views

125

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CEP panels / Enabling nodejs and mixed context makes Photoshop panel to not work

Explorer ,
Jul 27, 2020

Copy link to clipboard

Copied

Hello,

 

I'm building a small local server on as Photoshop panel because I need to use Nodejs for some tasks. The problem is that when I try to enable node js and mixed context on the Parameters under CEFCommandLine in the manifest.xml, doesn't seems to work.

 

When I open the extension that is loading the server, somehow it makes flicker the loader in my cursor like if something was loding but doesn't loads node-js, here's my manifest <extension> tag:
 

 

<Extension Id="cnation.server">
			<DispatchInfo>
				<Resources>
					<MainPath>./localServer.html</MainPath>
					<CEFCommandLine>
					<Parameter>--enable-nodejs</Parameter>
					<Parameter>--mixed-context</Parameter>
					</CEFCommandLine>
				</Resources>
				<Lifecycle>
					<AutoVisible>false</AutoVisible>
				</Lifecycle>
				<UI>
					<Type>Custom</Type>
					<Geometry>
							<Size>
								<Height>100</Height>
								<Width>100</Width>
							</Size>
						</Geometry>
					<Icons />
				</UI>
			</DispatchInfo>
		</Extension>

 

If I remove this two lines: the panel works well but I cannot use Nodejs on the browser to call a Nodejs function:

 

<Parameter>--enable-nodejs</Parameter>
					<Parameter>--mixed-context</Parameter>

 


Someone knows what is going on?

I just found the bug on this. Seems that if you have your extension folder name with some characters like "apostrophe" glitches because some parsing in the backend I think. But i removed the apostrophe and now it works perfectly, I had this issue for what, one month? It was driving me crazy!!

TOPICS
Actions and scripting, Bug, How to, Problem or error

Views

126

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 27, 2020 0
Adobe Community Professional ,
Jul 29, 2020

Copy link to clipboard

Copied

Hi,

What CEP version are you using?

Best regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2020 1
Explorer ,
Aug 06, 2020

Copy link to clipboard

Copied

Hello Charu! I just found the bug on this. Seems that if you have your extension folder name with some characters like "apostrophe" glitches because some parsing in the backend I think. But i removed the apostrophe and now it works perfectly, I had this issue for what, one month? It was driving me crazy!!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
Explorer ,
Aug 06, 2020

Copy link to clipboard

Copied

I just found the bug on this. Seems that if you have your extension folder name with some characters like "apostrophe" glitches because some parsing in the backend I think. But i removed the apostrophe and now it works perfectly, I had this issue for what, one month? It was driving me crazy!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0