Highlighted

Changes or bug in 21.1 lasso tool

Community Beginner ,
Feb 25, 2020

Copy link to clipboard

Copied

In previous versions of PS you could switch from the standard lasso to the polygonal tool in mid-selection by holding down the alt key, lifting the stylus and clicking to add anchors, then resume freehand selection by releasing the alt key. In 21.1, holding alt and lifting the stylus will cause your selection to complete if you are in mid-selection. It still functions normally if you START with the alt key (not useful as there is already a tool to do this).

 

Was this functionality removed intentionally, is it another bug or has it been configured to work in another way such as with a new key combo?

 

Any help would be appreciated!

I just 'fixed' it. I downgraded a single version (uninstall was required and automatic) and it worked, but of course the tool presets in that version are broken, so I upgraded back to 21.1 to see if I could find a setting that could possibly correct the problem before comitting to going back multiple versions -- but before I even looked I tested the lasso at it worked as it should.

 

In summary, I downgraded a single version, then updated again to resolve the issue.

 

NOTE: the uninstall will wipe out all of your settings so make sure you back everything up first.

TOPICS
Bug, Problem or error, Windows

Views

328

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Changes or bug in 21.1 lasso tool

Community Beginner ,
Feb 25, 2020

Copy link to clipboard

Copied

In previous versions of PS you could switch from the standard lasso to the polygonal tool in mid-selection by holding down the alt key, lifting the stylus and clicking to add anchors, then resume freehand selection by releasing the alt key. In 21.1, holding alt and lifting the stylus will cause your selection to complete if you are in mid-selection. It still functions normally if you START with the alt key (not useful as there is already a tool to do this).

 

Was this functionality removed intentionally, is it another bug or has it been configured to work in another way such as with a new key combo?

 

Any help would be appreciated!

I just 'fixed' it. I downgraded a single version (uninstall was required and automatic) and it worked, but of course the tool presets in that version are broken, so I upgraded back to 21.1 to see if I could find a setting that could possibly correct the problem before comitting to going back multiple versions -- but before I even looked I tested the lasso at it worked as it should.

 

In summary, I downgraded a single version, then updated again to resolve the issue.

 

NOTE: the uninstall will wipe out all of your settings so make sure you back everything up first.

TOPICS
Bug, Problem or error, Windows

Views

329

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 25, 2020 1
New Here ,
Feb 25, 2020

Copy link to clipboard

Copied

I was about to create a post about it. Same thing here, and it bugs me a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
Community Beginner ,
Feb 25, 2020

Copy link to clipboard

Copied

I just 'fixed' it. I downgraded a single version (uninstall was required and automatic) and it worked, but of course the tool presets in that version are broken, so I upgraded back to 21.1 to see if I could find a setting that could possibly correct the problem before comitting to going back multiple versions -- but before I even looked I tested the lasso at it worked as it should.

 

In summary, I downgraded a single version, then updated again to resolve the issue.

 

NOTE: the uninstall will wipe out all of your settings so make sure you back everything up first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 1
Explorer ,
Mar 20, 2020

Copy link to clipboard

Copied

Photoshop 21.1.1 has the problem fixed. However, now it makes wild, random selections when pressing Alt and using the lasso tool. That does not help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2020 0
Adobe Community Professional ,
Apr 15, 2020

Copy link to clipboard

Copied

Hello, could you post a video of what you experience? Did you try 21.1.2?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2020 0
Community Beginner ,
Oct 30, 2020

Copy link to clipboard

Copied

Using 2021

I had a similar problem on a Mac which I fixed by turning of Safari while using it.  That said the lasso and polygon selection tool are really jerky and lost the smoothness when I was using PSD 2019.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
angryf84 LATEST
Community Beginner ,
Nov 02, 2020

Copy link to clipboard

Copied

I've had to downgrade to 21.2.4 and it works great (well I still have to have my browser off).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 0