Could not save “Filename” because of a program error.

New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

I know this is a common problem, however I feel as if this may be slightly different. 

 

What is happening: I am opening an existing PSD file in Photoshop (version 22.3) and when I go to save over the existing psd 'save' it will present an error Could not save “filename.psd” because of a program error. It is important to note that I am opening a file from a NAS and saving back to the NAS. Specifically a QNAP NAS.

 

Furthernmore, when you check the file location, a new psd file exists under a random name such as "Adobe Photoshop 202029437706089542" where the numbers appear to be random. A new file like this appears everytime you try and save over the original psd file where the numbers change in the filename for each save. As you can imagine this is quite frustrating and creates a huge mess in folders over time. (see attached) The Adobe Photoshop file names are 'saves'. Now I'm pretty sure normally these files appear while a PSD is saving and then merge to create the PSD then they dissapear.

 

3 of us work off iMac's in our office, all working off the NAS at the same time, and this only happens to me. I've tried reinstalling photoshop, updating etc. Tried working off local hdd, which this error doesnt occur on local hdd. Which got me thinking it must be a permissions issue or something, but seems to happen intermittently. Any ideas?

TOPICS
Problem or error

Views

65

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation