eGPU - PS 2021 dosn't workt under Big Sur / grey area when open a file

New Here ,
Jan 12, 2021

Copy link to clipboard

Copied

Hey guys 🙂 The problem has been addressed several times, but I couldn't find a solution yet. Maybe there's someone here.

 

Hardware/Software: Big Sur on a MacBook pro 2020, PS 2021, eGPU Razor Core + Radeon RX5700 XT, all up to date.

 

- MacOS Catalina + PS 2020 - everything works perfectly. PS and Camera Raw detected the eGPU, no problems at work.

- MacOS Big Sur + PS 2020 - everything works perfectly. PS and Camera Raw have detected the eGPU, no problems at work.

- MacOS Big Sur + PS 2021 - Camera Raw detects the eGPU and works perfectly. PS 2021 opens images/files only as gray area.

 

I was able to isolate the problem, but the problem remains:

 

MacOS preference for PS 2021 > prefer external GPU > enable.

PS 2021 preferences > performance - the eGPU is detected correctly, but...
1. use GPU > enable > PS 2021 opens images as gray area
1a. use GPU > disable > PS 2021 opens images normally (because not the eGPU is used, but the MacBook GPU).

 

Camera Raw preferences > performance - the eGPU is detected correctly and works reliably.

 

Just to be sure that the problem is with PS 2021 and not Big Sur, I disabled the macOS setting for PS 2021 > prefer external GPU. Of course, now everything works normally because only the MacBook GPU is used.

 

I don't understand why PS 2020 worked correctly under Big Sur. And I don't understand why the current Camera Raw works correctly but PS 2021 doesn't.

 

I need the eGPU to work. Does anyone know the problem and have a solution? That would be great because otherwise PS is useless to me and I need to switch to a different working environment.

 

Thanks in advance and stay healthy.

TOPICS
Mac, Problem or error

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

eGPU - PS 2021 dosn't workt under Big Sur / grey area when open a file

New Here ,
Jan 12, 2021

Copy link to clipboard

Copied

Hey guys 🙂 The problem has been addressed several times, but I couldn't find a solution yet. Maybe there's someone here.

 

Hardware/Software: Big Sur on a MacBook pro 2020, PS 2021, eGPU Razor Core + Radeon RX5700 XT, all up to date.

 

- MacOS Catalina + PS 2020 - everything works perfectly. PS and Camera Raw detected the eGPU, no problems at work.

- MacOS Big Sur + PS 2020 - everything works perfectly. PS and Camera Raw have detected the eGPU, no problems at work.

- MacOS Big Sur + PS 2021 - Camera Raw detects the eGPU and works perfectly. PS 2021 opens images/files only as gray area.

 

I was able to isolate the problem, but the problem remains:

 

MacOS preference for PS 2021 > prefer external GPU > enable.

PS 2021 preferences > performance - the eGPU is detected correctly, but...
1. use GPU > enable > PS 2021 opens images as gray area
1a. use GPU > disable > PS 2021 opens images normally (because not the eGPU is used, but the MacBook GPU).

 

Camera Raw preferences > performance - the eGPU is detected correctly and works reliably.

 

Just to be sure that the problem is with PS 2021 and not Big Sur, I disabled the macOS setting for PS 2021 > prefer external GPU. Of course, now everything works normally because only the MacBook GPU is used.

 

I don't understand why PS 2020 worked correctly under Big Sur. And I don't understand why the current Camera Raw works correctly but PS 2021 doesn't.

 

I need the eGPU to work. Does anyone know the problem and have a solution? That would be great because otherwise PS is useless to me and I need to switch to a different working environment.

 

Thanks in advance and stay healthy.

TOPICS
Mac, Problem or error

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 12, 2021 0
New Here ,
Jan 17, 2021

Copy link to clipboard

Copied

Similar problem:

Running Big Sur with current version of Photoshop 2021, Macbook Pro 2018,  Radeon RX5700XT

Settings are "Prefer External GPU" is selected in "Get Info" when right clicking on app icon.

Preferences/ Performance/ "Graphics Processor Settings" select "Use Graphics Processor".

Open image file then screen goes grey, image is not visible.

I spoke with Adobe support about this problem and they said that multiple GPU's were not supported, and therefore the eGPU was not supported. Well when using Catalina Photoshop would allow the selection of the eGPU and worked fine.

Lightroom works fine in Big Sur with the eGPU selected.

The 2018 Macbook Pro has two built-in GPU's: the Intel UHD Graphics 630 and the Radeon Pro 560X.

Photoshop allows the Radeon Pro 560X to be selected and opens and shows the image.

Apple or Photoshop have a bug in their system and they're not assuming responsibility.

Come on guys. We earn livings by your software and we pay you enough that you should correct these problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2021 0