Export (save for web) animated gif

New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Hi, I'm learning how to creat animated gifs. When I export and save for web, I choose my file option (GIF), preset (Gif 128 Dithered) and colors (256). I preview it and everything works. When I click save it comes up as format (HTML and image), HTML only, or images only. And the extension is .html. When I hit save, it gives me a folder called images (but there is only one file, called .gif) and then it also gives me a file with .html. How do I get it so I have just one file that is an animated gif?

TOPICS
How to, Import and export, Mac

Views

167

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I should also note that I am using Photoshop 22.2 on a late 2015 imac.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

The HTML file should be in the folder that the folder Images is in. Images parent folder

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

When I put it in the same folder as the images and then click on the html file, the gif opens in a browser. If I put it in the folder with the images, it doesn't work (broken image).

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I can only see the animation if I click on the html file, not on the actual gif file.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Why did you move the html file into the images folder it belomgs in images parent folder. The HTML image tag has the image in the subfolder the HTLM file is in the images subfolder now that does not exists for you moved the HTML file.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Because you said "The HTML file should be in the folder that the folder Images is in. Images parent folder".

 

When I exported save as web (legacy) and then saved, this is what I got, just like this...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

I wrote the html file would be in the image folder parent folder.  You found it and moved it.  I did not write you should move the html file.  In fact I wrote that it should be there.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

OK, so I misunderstood you, and I moved it back out. However, it wasn't IN the image folder to begin with (apprarently that's a problem) and there was no "parent" folder (again apparently another problem), just the folder called "images" and then the html file, so what now? Can you see the picture I posted?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

I'll repeat  the html file should not be in the Images folder. The Images folder should be in the folder that the html file is in. The way Photoshop created them. Photoshop saved  the html file into the folder you set in save for web UI, created the imsges folder in that folder, and saved the gif file in the images folder.

 

 

If you open the html file in yourr browser the Gif will be displayed if the images folder is in the folder the html file is in.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

OK, I understand that. However, Photoshop DID NOT CREATE a parent folder. When I saved it, it only saved it as an  images folder and an html file. No matter where I save it (i.e. to my desktop, or within another folder on a another drive) it doesn't matter. Photoshop did not create a parent folder for this gif. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

That is correct  you pointed Save for Web to the parent folder to save into the Html file is saved and Photoshop makes an Images folder if  one did not exist where you pointed save for web to so there would be a images folder  for save for web to save the gif into. Photoshop is working correctly for you.  The only problem is you think you have some problem.  You do not.  Photoshop does not make the parent folder. You point Photoshop's  Save for web save dialog to the Parent folder to save the required files into.  Photoshop will make the folder images if it does not exists.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

OK, but what I don't understand is if I download a gif from the internet or even from an email, it gives me just the image, not an html file and image.  And then when I send it, it's only the image, not an html link. What am I missing?

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

OK, I exported (save as web (legacy)) again - I chose to save it to my desktop. Please review the image. There is no parent folder. This is exactly the way it saves.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Your Desktop folder is the parent folder you pointed Save for web to it. You desktop now has a Images folder with you GIF in it. Your Desktop folder is images folder parent. That Patent folder your contains an HTML file that displays  your gif from the images folder.  If you double click on the html file on your desktop your browser should display the gif in the images folder.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied


@jlhiller wrote:

When I click save it comes up as format (HTML and image), HTML only, or images only. And the extension is .html. When I hit save, it gives me a folder called images (but there is only one file, called .gif) and then it also gives me a file with .html. How do I get it so I have just one file that is an animated gif?


 

If you want just one file that is an animated GIF, you should not select “HTML and Images” in the Format menu. Select “Images Only” instead.

 

“HTML and Images” is usually for when you have created a design with multiple pieces that needs HTML code to hold it together, such as a document where you used the Slice tool.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

I tried that, but then I lose my animation. It becomes just an image only.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Also, I never touched the slice tool. I have literally two layers, that I made into frames. That's it. And they animate in photoshop and they animate in the preview (on the export screen), but when I save it, it only gives me those options. AND, it does not have the .gif extension at all. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Well, I’m not sure what the problem is. It sounds like you are doing everything right. If you select Images Only, you should get one animated GIF with a .gif extension at the end. I am using Photoshop 22.2 on macOS 10.15.7.

 

After looking at your helpful screen shots, I set up a new document the same as yours: Two frames, 0.2 second delay on both. It animates in the Timeline panel, and it animates in Save for Web when the Format set to GIF.

 

The difference is, when I export, I get an animated GIF that alternates between the two frames and loops, which is what I think you want. Also, my file has a .gif filename extension. So it’s puzzling why it isn’t working for you.

 

Ignore everything about setting the save format to HTML and Images, so that you do not have to deal with the folder nesting and all of that stuff. That is all a pointless side road that you don’t have to go down, because all you want is one animated GIF file. Stick with the Images Only route and focus on troubleshooting that, because it should work.

 

One big thing that could be a variable here: Your dialog box looks like you are using macOS 11 Big Sur. There seem to have been some problems related to the filename extension being filled in on that version of macOS. When the GIF is exported, do you add the .gif extension to it, or try to play it as is? Have you tried adding the extension and then see if it loops right on the desktop or in a web browser?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

When I choose images only and change the extention to .gif (because when I go to save it still says .html even when I choose images only) and save, it still gives me just an image without the animation, even though the extension now says .gif. Very frustrating!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

If you use the pull-down menu in save for web and select GIF only. Save for web will only save a GIF file there may be an old Previously saved .html file if you did not delete it.  Save for web will not delete old files it may overwrite old files it has no delete function.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

I've been selecting GIF in the pull down menu since the start (I was following Adobe Photoshop's "How to make an animated gif in Photoshop article". I followed it to the letter. Still having issues.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

If Photoshop is not working correctly reset all you Photoshop Tools and your Photoshop preferences. See it the solves your Photoshop issues when you restart Photoshop.  I use Windows you use a Mac there may be some Issues in Mac Photoshop versions I do not know of. There have been many changes apple has made to their OS and hardware lately.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines