Highlighted

Ghost layers on latest PS version

New Here ,
Jun 20, 2020

Copy link to clipboard

Copied

Hi all. I don't know if anyone experienced this but I updated PS to the latest version today and I have ghost layers, as if it wasn't refreshing.

I tried on an Asus monitor as well as my 4K Cintiq. Same issue. 

I'm on Mac OS 15.5.5

Also, when PS runs in the background, the content of my image disappears and is now just a grey. 

 

Topics

Bug, Mac, Performance, Problem or error

Views

107

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Ghost layers on latest PS version

New Here ,
Jun 20, 2020

Copy link to clipboard

Copied

Hi all. I don't know if anyone experienced this but I updated PS to the latest version today and I have ghost layers, as if it wasn't refreshing.

I tried on an Asus monitor as well as my 4K Cintiq. Same issue. 

I'm on Mac OS 15.5.5

Also, when PS runs in the background, the content of my image disappears and is now just a grey. 

 

Topics

Bug, Mac, Performance, Problem or error

Views

108

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 20, 2020

Copy link to clipboard

Copied

Hi

It's a bug Adobe introduced in the latest update, go into preferences and disable legacy compositing if it's enabled and restart Photoshop

2020-06-20 17_04_12-Window.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 28, 2020

Copy link to clipboard

Copied

Hi. Thanks for the answer. 

I tried and it's not changing anything. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
dsol21 LATEST
Explorer ,
Jul 27, 2020

Copy link to clipboard

Copied

I'm having the same issue here with Photoshop 2020 - it's not refreshing the comp buffer after moving a layer. Turning the layer on and off doesn't remove the "ghost" layer, but alt-clicking on the layer to turn off everything but the layer on and off does fix it. I've done a screen recording showing the issue. This utterly breaks Photoshop for me and is a critical bug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...