Highlighted

GPU seems unused with latest Ps CC 2020 21.2.4

New Here ,
Oct 19, 2020

Copy link to clipboard

Copied

Hello,

 

When I try to use the latest Ps version my graphics go funny. I have to resort to using 21.1.3 before my GPU seems utilized.

 

I am using an AMD Radeon HD 6570 on an old Dell PC. Is there a list of graphic processors usable with Ps or has that been taken off the site? The GPU has 1 GB of memory (like Adobe seems deem sufficient).

 

Do I need to get a new computer to use the latest Ps version?

 

Frustrated,

Richard

TOPICS
Performance, Problem or error, Windows

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

GPU seems unused with latest Ps CC 2020 21.2.4

New Here ,
Oct 19, 2020

Copy link to clipboard

Copied

Hello,

 

When I try to use the latest Ps version my graphics go funny. I have to resort to using 21.1.3 before my GPU seems utilized.

 

I am using an AMD Radeon HD 6570 on an old Dell PC. Is there a list of graphic processors usable with Ps or has that been taken off the site? The GPU has 1 GB of memory (like Adobe seems deem sufficient).

 

Do I need to get a new computer to use the latest Ps version?

 

Frustrated,

Richard

TOPICS
Performance, Problem or error, Windows

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 19, 2020 0
Adobe Community Professional ,
Oct 20, 2020

Copy link to clipboard

Copied

Hi

Photoshop version 21.2 and above has issues with some old and not so old GPU's more info

https://feedback.photoshop.com/conversations/photoshop/photoshop-212-not-detecting-older-gpus/5f5f46...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
Adobe Community Professional ,
Oct 20, 2020

Copy link to clipboard

Copied

The only Adobe advice now is this, rather than a list of cards it just states that "If your graphics card is older than 4 years, GPU functionality in Photoshop may be limited or not supported."

https://helpx.adobe.com/uk/photoshop/kb/photoshop-cc-gpu-card-faq.html

 

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

Thanks man. Seems it was listed as a bug and then became their standard. I
guess they figure if you've got an old gpu then Adobe will offer you an old
version.

Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0