GPU Sniffer Crashed - GPU not detected — TRIED EVERYTHING

New Here ,
May 01, 2021 May 01, 2021

Copy link to clipboard

Copied

PROBLEM

I recently noticed Photoshop was not utilizing my GPU, after navigating to my Performance Preferences (shift+k) I noticed the Graphics Processor Settings were grayed out and show, "Unkown GPU (UNKNOWN)". When I hover over it the description shows "Photoshop detected an error in your display driver". When I check the system info under the Help Tab it states that GPU sniffer has crashed, thus not providing my GPU info.

 

WHAT I HAVE TRIED

After a bit of research, I tried to fix the error by uninstalling my GPU drivers and installing the current studio drivers directly from NVIDIA.

I tried renaming the file "sniffer.exe", located in C:\Program Files\Adobe\Adobe Photoshop 2021, to something else like "~sniffer.exe". I tried moving the file "sniffer.exe" to any other folder besides "Adobe Photoshop 2021".  I tried deleting the file "sniffer.exe". I tried uninstalling and reinstalling the current version of Photoshop (22.3.1), as well as a previous versions of Photoshop (22.3 / 22.2 / 22.1.1 / 22.1 / 22.0.1 / 22.0 / 21.2.7).  I have also physically removed my GPU and tried it in the same PCIe slot as well as another slot, and ran "dxdiag.exe" and MSI Kombuster on both occasions, showing no problems, so I am very confident my GPU is not the problem. None of these worked.

 

ADDITIONAL INFO

Adobe Photoshop Version: 22.3.1 20210406.r.122 990be2c x64
Number of Launches: 1208
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.19041.928
System architecture: Intel CPU Family:6, Model:14, Stepping:13 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading
Physical processor count: 8
Logical processor count: 16
Processor speed: 3600 MHz
Built-in memory: 32602 MB
Free memory: 20003 MB
Memory available to Photoshop: 29855 MB
Memory used by Photoshop: 67 %
SAM SDK Version: 2.0.0-main.363.5
ACP.local Status:
- SDK Version: 1.41.1.1
- Core Sync Status: Reachable and compatible
- Core Sync Running: 4.11.0.12
- Min Core Sync Required: 4.3.28.24
ACPL Cache Config:
- Time to Live: 5184000 seconds
- Max Size: 20480 MB
- Purge Percentage: 50%
- Threshold Percentage: 85%
- Purge Interval: 60 seconds
Live Edit Client SDK Version: 3.79.23
Presets Status:
- Brushes: 56 local / 0 synced
- Gradients: 184 local / 0 synced
- Patterns: 21 local / 0 synced
- Shapes: 108 local / 0 synced
- Styles: 21 local / 0 synced
- Swatches: 122 local / 0 synced
Manta Canvas: Enabled.
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Disabled.
Wintab Digitizer Services
Spec Version 2.0
Impl Version 2.0
Num Devices 1
Image tile size: 1024K
Image cache levels: 4
Font Preview: Medium
TextComposer: Latin
The GPU Sniffer crashed on 5/1/2021 at 8:50:32 PM
------- GPU
OpenGL API stable: False
OpenCL API stable: False
Native API stable: False
GPUDeny: 0
GPUForce: 0
useGPU: 0
isCapableGPU: 0
GPUName: Unknown GPU
GPUVendor: UNKNOWN
IsOpenGLGPUCapable: 0
IsNativeGPUCapable: 0
HasSufficientRAM: 0
VRAM: 0 MB
Required VRAM: 1,500 MB
UseGraphicsProcessorChecked: 1
UseOpenCLChecked: 0
Windows remote desktop: 0
GPU Allow Normal Mode: False
GPU Allow Advanced Mode: False
GPU Drawing Mode: Basic
Display: 1
Display Bounds: top=0, left=0, bottom=2160, right=3840
Display: 2
Display Bounds: top=313, left=-1920, bottom=1393, right=0
------- GPU

TOPICS
Bug, Problem or error, Windows

Views

133

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 01, 2021 May 01, 2021

Copy link to clipboard

Copied

LATEST

Seems I may have found a temp fix. 

I had to downgrade Photoshop to ver22.3, go into device manager disabled any other Display Adapters, then rename "sniffer.exe" and move it to another folder. Under Help tab - System Info it still shows GPU sniffer crashed, but now my GPU info appears. Also, my GPU is now detected under Performance Preferences - Graphic Processor Settings. 

Seems to be working fine so far. Hope this helps others with the same problem I had.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines