How avoid the hyphen in filename when saving ?

Explorer ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

I am working on mac, I have lots of photoshop files, I want to create output of those files as web jpeg my file naming is "xxxx xxx x" but when I save it or try to replace it the naming converts in to "xxxx-xxx-x" ie hyphen is added, so every time I have to rename files after saving as jpeg... I can't go for save as option becaz save for web is mandatory...

please help its is quite urgent...

Thanks in advance...

Views

3.4K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jan 09, 2017 Jan 09, 2017
In any case, if you really want to avoid the web taxonomy rule there is a way.Choose "Save for web..." and then choose "Save"now from the following window choose "Other" from the "Settings" dropdown menùand now in the following window "Output Settings" just choose "Space" instead of "hyphen"from the file naming option dropdown menuHope this can solve your issue

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

You can use underlines instead: xxx_xxx.

You do appreciate that you can't have word spaces in web file names?

Also Save for Web has been deprecated, use Save As or Export As.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

I need spaces, no hyphen or underlines

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

hello abhijeett89122812 
In which way are you saving your jpg files? Since if you save it via the "file/save as..." your file name are not forced to use the hyphen, if you are saving  instead via "export as..." or "Save for web..."  this way is intended for exporting files for the web were, because of the taxonomy web rules, you cannot use spaces.

So if you are saving a single file or small group of files just go via "Save as...", if you are saving a large group of files/levels or parts of a sliced image you are bound to the web taxonomy rules who don't use spaces.

Hope this can help.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

The web does not allow spaces in URLs. So Photoshop fixes this error.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

the web taxonomy rules also do not accept spaces in filenames

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

In any case, if you really want to avoid the web taxonomy rule there is a way.
Choose "Save for web..." and then choose "Save"

Screen Shot 2017-01-09 at 16.24.59.png

now from the following window choose "Other" from the "Settings" dropdown menù

Screen Shot 2017-01-09 at 16.25.38.png

and now in the following window "Output Settings" just choose "Space" instead of "hyphen"from the file naming option dropdown menu
Screen Shot 2017-01-09 at 16.25.58.png


Hope this can solve your issue

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 09, 2017 Jan 09, 2017

Copy link to clipboard

Copied

helpful, thanks!!! but I am facing new problem my psd file name is "pstacross" I want to save as web jpeg with naming "pstacross Frame 1" i.e I want this text at end of file name " Frame 1" every time I save web jpeg I possible this can be saved as settings for further use

thanks in advance...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

It doesn't work permanently. You need to redo any time you made a new document and it is boring...
So "Quick Export As PNG" from drop menu on layers works well with spaces all the times, and "Save For Web" just not.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

In Save for Web go to Output Settings>Saving Files and uncheck Unix.

 

osa.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines