How to stop Photoshop from accidentally selecting layers overlapping or near layer I am working on

Explorer ,
Dec 05, 2019

Copy link to clipboard

Copied

It truly drives me nuts that often when I click on a layer (in the layers panel) to then do something directly to that layer on the canvas, it many times will start working on / activate a different overlapping or adjacent layer, most times an adjustment layer. But of course it could be any layer that happens to be in the same vicinity.

 

Is there any way to deactivate this? Photoshop didn't used to do this. You had to click on a layer (in the panel) to change it or work on it. My workaround is to temporarily lock or hide the layer I don't want to accidentally select, but it is silly that I have to do that.

 

Whoever thought that clicking on a layer (to change to another layer) directly on the canvas was a good idea, probably doesn't actually USE photoshop on a regular basis. I cannot be the only person who hates this (?) Help!

Adobe Community Professional
Correct answer by SJRiegel | Adobe Community Professional

You must have auto-select (layer or group) selected. This has been an option for a long time - uncheck it and you should be fine.

Screenshot 2019-12-05 14.28.07.png

TOPICS
How to, Mac, Problem or error

Views

333

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to stop Photoshop from accidentally selecting layers overlapping or near layer I am working on

Explorer ,
Dec 05, 2019

Copy link to clipboard

Copied

It truly drives me nuts that often when I click on a layer (in the layers panel) to then do something directly to that layer on the canvas, it many times will start working on / activate a different overlapping or adjacent layer, most times an adjustment layer. But of course it could be any layer that happens to be in the same vicinity.

 

Is there any way to deactivate this? Photoshop didn't used to do this. You had to click on a layer (in the panel) to change it or work on it. My workaround is to temporarily lock or hide the layer I don't want to accidentally select, but it is silly that I have to do that.

 

Whoever thought that clicking on a layer (to change to another layer) directly on the canvas was a good idea, probably doesn't actually USE photoshop on a regular basis. I cannot be the only person who hates this (?) Help!

Adobe Community Professional
Correct answer by SJRiegel | Adobe Community Professional

You must have auto-select (layer or group) selected. This has been an option for a long time - uncheck it and you should be fine.

Screenshot 2019-12-05 14.28.07.png

TOPICS
How to, Mac, Problem or error

Views

334

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 05, 2019 0
Adobe Community Professional ,
Dec 05, 2019

Copy link to clipboard

Copied

You must have auto-select (layer or group) selected. This has been an option for a long time - uncheck it and you should be fine.

Screenshot 2019-12-05 14.28.07.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2019 2
Sara W LATEST
Explorer ,
Dec 05, 2019

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2019 0