Highlighted

Images look over saturated in Photoshop, regardless of profile.

Explorer ,
Mar 06, 2019

Copy link to clipboard

Copied

I'm having problems importing images into Photoshop that have no color profile. The problem is that whatever option I select in the 'Embedded Profile Mismatch' popup screen, the image looks very oversaturated once it shows up. This typically happens with images that come from the internet. They look fine in my browsers, and they look the same in Preview. It's only when I open the image in PS that it looks very oversaturated. I have attached a screen dump of the image opened in PS and in Preview (left). What I don't understand is how neither of the options in the 'Embedded Profile Mismatch' give me a look that resembles the one I get in Preview or in my browser. Any ideas?

Screen Shot 2019-03-07 at 12.24.32.png

Adobe Community Professional
Correct answer by Michael Bullo | Adobe Community Professional

Hi Marsel,

Try going to…

     Edit > Assign Profile

and assigning a profile to your untagged files (ie those with no embedded profile). The sRGB profile would be the best place to start.

Michael

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Images look over saturated in Photoshop, regardless of profile.

Explorer ,
Mar 06, 2019

Copy link to clipboard

Copied

I'm having problems importing images into Photoshop that have no color profile. The problem is that whatever option I select in the 'Embedded Profile Mismatch' popup screen, the image looks very oversaturated once it shows up. This typically happens with images that come from the internet. They look fine in my browsers, and they look the same in Preview. It's only when I open the image in PS that it looks very oversaturated. I have attached a screen dump of the image opened in PS and in Preview (left). What I don't understand is how neither of the options in the 'Embedded Profile Mismatch' give me a look that resembles the one I get in Preview or in my browser. Any ideas?

Screen Shot 2019-03-07 at 12.24.32.png

Adobe Community Professional
Correct answer by Michael Bullo | Adobe Community Professional

Hi Marsel,

Try going to…

     Edit > Assign Profile

and assigning a profile to your untagged files (ie those with no embedded profile). The sRGB profile would be the best place to start.

Michael

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 06, 2019 0
Adobe Community Professional ,
Mar 06, 2019

Copy link to clipboard

Copied

Hi Marsel,

Try going to…

     Edit > Assign Profile

and assigning a profile to your untagged files (ie those with no embedded profile). The sRGB profile would be the best place to start.

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2019 3
Explorer ,
Mar 07, 2019

Copy link to clipboard

Copied

Thank you very much, that helped.

But shouldn't I be able to get the same results when opening the image and assigning an sRGB profile to it while opening? Whatever I select in that profile mismatch window, the image doesn't change its colors. I can't remember this behavior, which is why I'm confused.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0
Adobe Community Professional ,
Mar 07, 2019

Copy link to clipboard

Copied

Hey Marsel. That's great that works.

Correct me if I'm wrong, but you are particularly interested in what to do when you open a file without an embedded profile, right? If so, wouldn't you be better off turning on Missing Profiles within the Color Settings dialog box?

color-settings-missing-profiles.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0
Adobe Community Professional ,
Mar 07, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Marsel+van+Oosten  wrote

But shouldn't I be able to get the same results when opening the image and assigning an sRGB profile to it while opening? Whatever I select in that profile mismatch window, the image doesn't change its colors. I can't remember this behavior, which is why I'm confused.

That shouldn't happen. When you assign sRGB, the image should display correctly from that point (assuming sRGB is the right profile, but if it's from the web it will be).

If it doesn't, something's wrong. It could be that Photoshop is in fact not using the right monitor profile for the screen it's on. That happens occasionally, with multi-screen setups. It's a clear bona fide bug, but impossible to say whether it's in the application or the OS or both.

It could also be a video driver bug (for macOS that translates to an OS bug, needing an OS update).

Or it could be a strange anomaly that's occasionally reported with Photoshop. When you convert or assign a profile, the initial preview is wrong. Toggle once, and it goes away. This isn't really a bug because the data are correctly handled, the conversion itself is performed correctly. It's just the first-time preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0
Explorer ,
Mar 07, 2019

Copy link to clipboard

Copied

Michael - all those boxes are checked because I want to know when I open a file that has no or the wrong color profile. Assigning a profile in the Color Profile Mismatch popup window has no effect on the appearance of the image, it's only the Menu > Assign Profile option that you suggested that works. It's very confusing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0
New Here ,
Sep 23, 2020

Copy link to clipboard

Copied

Marsel,

Try going to Edit > Color Settings and then when the "Color Settings" window pops up look under Advanced Controls and if the box next to "Desaturate Monitor Colors By" is checked, uncheck it. I hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2020 0
Adobe Community Professional ,
Mar 06, 2019

Copy link to clipboard

Copied

Never work with untagged material. Assign the correct profile ASAP. Untagged images on the internet can be safely assumed to be sRGB, so that's the profile to assign.

Newer versions of Safari (and Firefox and Chrome) assign sRGB to all untagged material. This is what allows correct color management to proceed - which is absolutely required with wide gamut displays, whether traditional wide gamut or the Apple variety P3. If the browsers didn't do that you'd get oversaturation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2019 2
Adobe Community Professional ,
Mar 07, 2019

Copy link to clipboard

Copied

Wait a second. Are you just clicking the radio buttons, or are you actually trying different profiles in the rolldown? That's what you need to do.

The advantage of the Missing Profile warning is that you get to try different profiles immediately, so that you can assign what looks like the right one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0
Explorer ,
Mar 07, 2019

Copy link to clipboard

Copied

Well, that's the thing - it doesn't matter which profile I select from the pull-down menu, the results are all the same (no change). It used to work, but it no longer does.

Everything is up to date, and I tried rebooting - nothing helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2019 0