Highlighted

Incorrect text character being displayed

New Here ,
Nov 28, 2018

Copy link to clipboard

Copied

I am seeing a strange behavior that I can't explain.  When typing text, if I type an apostrophe (') a greater than sign (>) appears instead.  If I type (>), the screen displays (>), just like it should.  It does this for every font.  If I go to Type==>Panels==>Glyphs and double-click on ('), I get the same behavior.

Two things of note:

  1. I have PS running on two machines and this occurs on only one of them, so I'm ruling out a software bug in PS.

  2. If I do the same test in Word or Excel, the problem does not exist.

I'm guessing there is some sort of character mapping algorithm that is messed up, but I can't find a reference to such a function.

Ideas (short of uninstall/re-install)?

Oh, BTW, my environment is: latest version of PS CC running on Win10 Pro.

--Ernie

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Incorrect text character being displayed

New Here ,
Nov 28, 2018

Copy link to clipboard

Copied

I am seeing a strange behavior that I can't explain.  When typing text, if I type an apostrophe (') a greater than sign (>) appears instead.  If I type (>), the screen displays (>), just like it should.  It does this for every font.  If I go to Type==>Panels==>Glyphs and double-click on ('), I get the same behavior.

Two things of note:

  1. I have PS running on two machines and this occurs on only one of them, so I'm ruling out a software bug in PS.

  2. If I do the same test in Word or Excel, the problem does not exist.

I'm guessing there is some sort of character mapping algorithm that is messed up, but I can't find a reference to such a function.

Ideas (short of uninstall/re-install)?

Oh, BTW, my environment is: latest version of PS CC running on Win10 Pro.

--Ernie

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 28, 2018

Copy link to clipboard

Copied

Reset Type Tool  First select the Type Tool and right-click on its icon at the top.

Screen Shot 2016-01-18 at 12.39.07 AM.png

and Reset Character Panel

Screen Shot 2018-11-28 at 11.25.37 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 29, 2018

Copy link to clipboard

Copied

Check your keyboard input language settings. Sometimes it changes for no apparent reason, and then you may get some incorrect characters like you describe. Happens to me occasionally, and then a quick glance at the taskbar reveals the problem.

language.png

Unless you have an all-English setup with no other language or region involved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 29, 2018

Copy link to clipboard

Copied

So many keyboards.  So many different character maps.  This page has made me feel arrogant for assuming that my 'US' layout was a sort of world standard, but the 'greater than', and 'lesser than' characters are on the other side of the keyboard on about half of these.

International Keyboards Mapping

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 29, 2018

Copy link to clipboard

Copied

Yeah. Some of the standard PS shortcuts don't work at all here, like the square brackets.

And sometimes the other shortcuts don't take at all in Photoshop, just no reaction. Funnily enough, there's one that always works, and that's ctrl+alt+shift+K, which brings up the keyboard shortcut dialog. Dismiss that with Enter, and all the other shortcuts come back to life.

I can't explain this, but I suspect that too is related to using a Norwegian keyboard with English Photoshop and English Windows. It must be, since I have it in two machines, but no one else seems to have this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Apr 02, 2020

Copy link to clipboard

Copied

In Edit>Prefrences>type disable smart Quotes.
I had the same problem and this solved for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 06, 2020

Copy link to clipboard

Copied

Worked for me thanks.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 15, 2020

Copy link to clipboard

Copied

Thanks, that was the solution that worked for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

I'm trying to find this same solution for Illustrator but Edit doesn't seem to have a "preferences" option. In my text, like the poster's same issue - I am getting > instead of ' and ≫ instead of ".

I can't find any conversation about this issue for Illustrator anywhere. Only here on this thread for Photoshop. I would assume there would be similar fix and I am not sure how this just started happening. Does anyone know a fix for the same issue in Illustrator? It doesn't happen outside of Illustrator. Not in any MS platforms like word or excel. Only Adobe.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...