Highlighted

Lasso tool causes crash in Photoshop CC 2019

Community Beginner ,
Oct 17, 2018

Copy link to clipboard

Copied

Updated to Photoshop CC 2019 yesterday. Using the lasso tool (standard, polygonal, or magnetic) causes an immediate crash.

I've tried resetting all Photoshop settings, but it makes no difference. Is anyone else having this issue? I'm going to have to reinstall CC 2018 if I can't find a solution.

Running on Windows 7 Pro (work computer, so upgrading is not an option at this time).

Pedro

Hi, Can you  please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and also check the option located in Preferences > Performance > Legacy Composting.

Thanks.

Views

5.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lasso tool causes crash in Photoshop CC 2019

Community Beginner ,
Oct 17, 2018

Copy link to clipboard

Copied

Updated to Photoshop CC 2019 yesterday. Using the lasso tool (standard, polygonal, or magnetic) causes an immediate crash.

I've tried resetting all Photoshop settings, but it makes no difference. Is anyone else having this issue? I'm going to have to reinstall CC 2018 if I can't find a solution.

Running on Windows 7 Pro (work computer, so upgrading is not an option at this time).

Pedro

Hi, Can you  please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and also check the option located in Preferences > Performance > Legacy Composting.

Thanks.

Views

5.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 17, 2018 3
Advocate ,
Oct 17, 2018

Copy link to clipboard

Copied

Hi, Can you  please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and also check the option located in Preferences > Performance > Legacy Composting.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 17, 2018 5
Community Beginner ,
Oct 18, 2018

Copy link to clipboard

Copied

Yes, that fixed it. Seems like it's only in Windows 7, because it doesn't happen on Windows 10 at home.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2018 0
Adobe Community Professional ,
Nov 08, 2018

Copy link to clipboard

Copied

Hi

By disabling "Use Graphics Processor" you will lose some Photoshop functionality that requires a GPU, more info

Photoshop graphics processor (GPU) card FAQ

Instead of disabling it, try setting the Drawing Mode to Basic in the Advanced Settings and restarting Photoshop

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2018 0
Community Beginner ,
Nov 08, 2018

Copy link to clipboard

Copied

I had the same problem (macOS Mojave, MacBook Pro, Retina, 15", mid 2015).

Photoshop looks like crap now, but it fixed the probelm, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2018 0
Advocate ,
Nov 08, 2018

Copy link to clipboard

Copied

welcome!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2018 0
New Here ,
Sep 22, 2019

Copy link to clipboard

Copied

Hi Muqqarib, that's fixed it! Thanks!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2019 0
New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Thank You - Thank You - Thank You

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Nov 06, 2019

Copy link to clipboard

Copied

even if this solves the problem, it cuts away features from Photoshop I would like to use, like for example rotating the canvas. I hope this can be fixed soon in upcoming updates! I am using windows 10 Intel i5-2500@3.3Ghz 16Gb Ram and a GTX 1060 6Gb if this is any use to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2019 1
New Here ,
Nov 25, 2020

Copy link to clipboard

Copied

спасибо, помогло!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2020 0
Community Beginner ,
Dec 29, 2019

Copy link to clipboard

Copied

This is still a bug in PS 2020...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 29, 2019 0
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

wrong one

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2020 0
New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

Just uncheck "Anti-alias Guides and Paths" from Advanced Graphics Processor Settings. It works for me. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2020 1
New Here ,
Apr 17, 2020

Copy link to clipboard

Copied

it works for me too Windows10 , PS release 20.09.tks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0
New Here ,
Jun 02, 2020

Copy link to clipboard

Copied

It works for me win 10 🙂 thx

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2020 0
Engaged ,
Nov 17, 2020

Copy link to clipboard

Copied

Solution 1: Deselect "Use Graphics Processor"

Doesn't work: This disables scrubby zoom, making Photoshop completely unuseable!

 

Solution 2: Change "Drawing Mode" to "Basic"

—Had no effect on my machine

 

Solution 3: Disable "Antialias Guides and Paths"

WORKS PERFECTLY!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2020 0
New Here ,
Nov 25, 2020

Copy link to clipboard

Copied

спасибо, ура, помогло!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2020 0