Liquify tool not working with latest PS update

New Here ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

I just did the latest PS update and now my liquify tool isn't working. When I open it the screen is blank grey and the cursor is a round fuzzy circle. Can anyone advise me on how to remedy this as I have client photos to do and can't afford this delay. 

Thanks

TOPICS
Bug, Performance, Problem or error, Windows

Views

74

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

I just posted this exact same question. I posted a picture of that circle thing. I hope someone responds because I need this tool to do my job.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Is your graphic card driver up to date ?

have you tried tried resetting photoshop preferences settings?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines