Match layers across frame not working

New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Hi, i'm literally just trying to move a gif to a still image. 

I've copied and pasted the frames of the gif into the still image i'm trying to paste it into, now to have the images actually be over the background.

But when I select match layer across frames, the gifs are still transparent, and I end up creating a gif that flashes from background to gif 1, to gif 2, etc.

How do I fix this?

TOPICS
How to, Problem or error

Views

1.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Could this be a photoshop version thing? I'm using the 2021 version.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2020 Nov 02, 2020

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

I am having exactly the same issue. I know it started with the latest version. 

I cannot get the "match layer across frames" to fill in properly. I know the steps are all correct. I have been making animations on still images for quite awhile. Did you get any go around or date when this bug will be fixed?

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

I spent hours today, on chat line with two Adobe Support Reps. The first rep had me rename the settings file, reboot, relaunch PS. Did not work.

The second rep said that I had to upgrade my display drivers. Not really willing to do this, until I see in writing from Adobe, that this is the problem. My drivers were updated on Dec. 8. 2020. Not that old. Still having the same issue you described. Paste the frames, then match layer across the frames and the gifs are still transparent. ...and yes, flashes from the background. Just like your problem. 

If this is a problem with display drivers, then why was it not recommended to upgrade drivers before the PS upgrade? This solution does not make sense. 

Vivi Wyngaarden Photography

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue? 

 

Could you please post screenshots with the pertinent Panels (Toolbar, Layers, Timeline, Options Bar, …) visible and the gif? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Thank you in advance for your response. I just tried unchecking the Graphic Proc Settings, relaunched PS and it did not help. I took screen shots to show you my PS work after I copied over the frames, pasted them, and hit Match layer across frames.  Also, the screen shot of just the gif. It is a very simple gif, without many frames. This way we can prove it has nothing to do with a memory issue. You can see it does not populate the frames. 

I have step by step instructions on how I did this in an attached word doc. 

 

I am also attaching an older and successful image (gif) to prove that I have performed this in the past. It is actually very easy. It seems the issue is with the newer upgrade to PS. 

Vivi Wyngaarden Photography

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Please, for the love of all that's holy, people, use this when posting images, else we have to try and divinate your images.

insertimage.jpg

 

I'm trying to repro this but having no issue. Positioning, style and visibility options all work as they should. Does this happen with new documents? All documents?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

This happens will all my images and gifs. I have performed this many times and did not have any issues. 

I am not sure what is different between our systems, or rev level. Here is mine, in case I did not upload it before. 

Screenshot 2021-04-07 11.54.17.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

The background layer does not seem to be selected in the Layers Panel, so which Layer exatly did you Match? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Hello, that is exactly what is wrong. None of them match. I tried to match across layers, so they used to all get selected. 

I am sorry that I did not upload the attachments properly. I used the tool at the bottom. 

Do you want me to upload again, using the tool you requested? 

Vivi Wyngaarden 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

In the timeline select all the frames (i.e. click the first frame and shift click on the last frame). With all frames still selected, go to the layers panel and turn off the eye symbol on the background layer then turn it on again.

The background layer should now be on in all frames

 

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Hello. 

After I pasted all the gif frames to still image, I performed what you suggested. 

Interesting: I highlighted all the frames, turned off the background and layer 1 populated with the background, so I did it for the rest of them. One by one a frame would populate with the background layer. 

I am closer than I have ever been. However, the gift still does not work. When I hit play, the "deer" in my case does not move. 

Here is a screen shot of the PS after performing the steps. 

 

Thank you so much for assisting me. That goes for all on this site. 

I am uploading the screen shot through this dialog. 

Screenshot 2021-04-07 11.48.03.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

It almost looks like a frame is (or frames are) still "on" when it (they) should be off.

 

Like dave said, I'd like to see this sucker for myself. No reason why it shouldn't be working properly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Sorry for the typo "gif".

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Hi

You can manually set whatever layers you want to show for any frame. So step through each frame in turn and, if the wrong layers are showing, turn on/off the eye icons in the layers panel so the correct layers are displayed.

 

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Hi There, 

Yes, I understand that. The background should be on all the layers, the gif should be placed on top of the layers too. 

However, the fact remains that the gif file does not work, does not move when played. 

I see make it larger and move it around with no problem, I can literally see it on all layers. It is just a still. 

Your next question might be, can you play this gif before you copy it over to the still image? The answer is yes. It will play before all the frames have been copied over. 

The same problem remains, once I try to match layers across frames, it does not work. I can manually make the background on each frame, and again,, it still does not work (does not play). 

Thank you again for trying so hard. 

Vivi Wyngaarden 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Could you post your gif? 

 

I may be misunderstanding but it sems I can’t reproduce the issue (see screenshots). 

matchLayerFrames.gif

Screenshot 2021-04-08 at 08.08.17.pngScreenshot 2021-04-08 at 08.08.51.pngScreenshot 2021-04-08 at 08.09.01.pngScreenshot 2021-04-08 at 08.09.10.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Can you save your file as a PSD then post a link to your PSD file, using Dropbox or similar. That way we may be able to see why it will not play.

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Yes. I will post my gif and upload it to Drop Box. Thank you again. Will copy link and send in reply. 

Give me a bit, shooting soon. 

Vivi Wyngaarden

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

 

"With all frames still selected, go to the layers panel and turn off the eye symbol on the background layer then turn it on again.

The background layer should now be on in all frames"
I never had to do that when clicked on  match layers across frames-I did this gif that way. 

 I unchecked the layers before playing, as War Unicorn suggested:

"It almost looks like a frame is (or frames are) still "on" when it (they) should be off."Screenshot 2021-04-08 10.54.44.pngScreenshot 2021-04-08 10.54.58.pngScreenshot 2021-04-08 10.55.07.png

Including screen shots so you can see all layers unchecked, except like your sample. 

 

Thank you both very much! 

Here is the link for the final gif. I did not flatten layers. 

https://www.dropbox.com/sh/kzxcc8tqq09x9kv/AACsvre9fqRBWPCC4O9z2u62a?dl=0

 

I truly appreciate your constant assistance with my issue. 

All the best, 

Vivi Wyngaarden 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Hmm...I downloaded the GIF...but it's a single frame? (Usually, animated GIFs are able to be viewed frame-by-frame in Photoshop, which I find strange.) Any chance we can look at the actual PSD?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

Of course. 

I used the same image and same gif, but recreated the scenerio to create and save PSD. 

I have uploaded an un flattened .PSD file and it is in the same Drop Box. Here is the link again: 

https://www.dropbox.com/sh/kzxcc8tqq09x9kv/AACsvre9fqRBWPCC4O9z2u62a?dl=0

 

I had to populate each layer with the background image, by the same method you mentioned before. Clicking on a layer and then turning off/on the background layer. 

 

Thank you again. 

Vivi Wyngaarden

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

Hi

I opened your PSD. Issue number one is that all your frames were set to the same layers (background and layer one).

So I stepped through each frame in turn and set the appropriate layers (using the eye icons) to show in that frame. So the first frame is Background and layer one

The second frame is background and layer 2

....etc

 

Then I used File > Export > Save for Web (legacy) to create the gif (I've made it at 50% just to save on the size for posting here)

7P8A0553-w-deer-gif.gif

 

That is it

 

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2021 Apr 09, 2021

Copy link to clipboard

Copied

I an trying really hard to follow. Do you mean to simply turn on all layers? 

I keep re reading your post, and following it, I did turn on all layers. 

Mine now,, seems to work. 

Is that all it is? Turn the "eye" on all layers then play?

Vivi Wyngaarden

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines