Missing "Content-Aware" and "Delete Cropped Pixels" boxes in PS Version 22.3.1

New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

When activating Crop Tool,  "Content-Aware" and "Delete Cropped Pixels" boxes are missing, not just greyed out.   They were visible probably a month or less ago and worked perfectly.   Perhaps they went missing with the last update to  PS Version 22.3.1?    I have been on an Adobe forum and they indicated if the image is a "Smart Object" or the locked "Background" image these boxes will not be available.  My photos were neither.   I've tried with both raw and jpgs.  I have tried closing PS and rebooting my computer a couple of times, to no avail.   I'm running PS on Mac OS Catalina 10.15.7.   Is this a glitch in Photoshop?   Please help me with this very frustrating problem.

 

 

TOPICS
Problem or error

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 04, 2021 May 04, 2021
Looks like you have Narrow Options Bar enabled. Narrow Options Bar Narrow Options Bar Off Photoshop>Preferences>Workspace and uncheck Enable Narrow Options Bar (Edit>Preferences>Workspace on windows)

Likes

Translate

Translate
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

I'm guessing you are on the Perspective Crop tool, not the standard Crop. Go to your tool bar, hold down on the crop icon and change to Crop.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

 I'm in the standard crop mode and it won't work.   But, thank you for your response.   Here is a screen save.

 

 

Screen Shot 2021-05-04 at 8.59.51 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

The thing is Smart Object pixels can not be change with Photoshop tools therefore it is not possible to crop a Smart object Layer.  However you cab crop the document the Smart object layer is in. On Windows I see both options in the Crop tools option bar. However if the Smart object layer is the only layer in the document. Content Aware is grayed out.  Delete cropped Pixels  is not grayed out. So I can check it. And  when I crop the document the Pixels are gone. However what was actually cropped was the documents Canvas size, The Smart object is basically clipped by the Document canvas. The Smart object layer is being masked by the documents canvas size.

Capture.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

As I understand it as I stated in my original question, a Smart Object or a Locked Background copy will not allow "Content-Aware"  cropping or "Delete Cropped Pixels"  and the boxes would be greyed out.   My problem is my photos are not Smart Objects or Locked Background Copies, and the boxes aren't greyed out; they are completely absent.   These features have been available in the past.   I've attached a screen save.  Thank you for your response, and hopefully you or someone else can help.

 

Screen Shot 2021-05-04 at 8.59.51 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Looks like you have Narrow Options Bar enabled.

 

Narrow Options Bar

 

Screenshot-(51).jpg

 

Narrow Options Bar Off

 

Screenshot-(51a).jpg

 

 

Photoshop>Preferences>Workspace and uncheck Enable Narrow Options Bar

(Edit>Preferences>Workspace on windows)

 

Screenshot-(53).jpg

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

LATEST

Thank you so much, Jeff!  You solved the problem!   I don't know how the Narrow Options got enabled.   Once I turned it off, works like a charm!   End of day of much frustration.   Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines