Mouse Lag when Switching Windows or Tools in PS 2018 and 2019 - And all Creative Cloud Apps!

Contributor ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

In any creative cloud app, including Photoshop CC 2018 or 2019, whenever I switch tools or windows, I get 2 to 3 seconds of jumpy / jerky mouse lag. I can easily duplicate it in Photoshop:

 

  • Fresh clean install of PS 2019 (or 2018)
  • New document on a freshly restarted Windows 10 desktop
  • Move tool is highlighted by Default
  • Select Crop Tool, Gradient Tool, or most other tools and the mouse goes all laggy for 3 seconds before "smoothing out".

 

Likewise, I can push the Collapse to Icons button on the Learn Photoshop tab (or any other tab) and it'll do the same thing - whatever tool I have selected in PS will go laggy for 3 seconds.

 

This happens in every other CC application as well. Adobe Audition? Click on the Effects window (I don't have to actually add any effect, just click on the window) and then click on the main sound wave window and it'll lag the exact same way, regardless of if a file is open or not. Adobe Premiere? Click on a clip, drag it to the Timeline, and the Timeline will cause the mouse lag.

 

When it's lagging, if I keep moving the mouse in rapid circles, the lag will never go away. If I stop moving the mouse for about 2 seconds, it smooths out and returns to the regular non-lag cursor movement.

 

I'm baffled as to what the problem could be. It happens on CC 2018 and CC 2019, both after clean installs. It makes using any CC product impossible.

 

  • This does not happen on any other application, game, browser, or item on my Windows 10 desktop
  • My Windows 10 desktop is fully updated and was freshly installed to a clean drive about a month ago
  • The issue persists on CC 2018 or CC 2019. I've done fresh clean installs of both.
  • If you want to see what the lag is like, set your monitor to 30hz or lower and move the mouse in circles. Notice how it's laggy / sloppy / chunky.
  • Remember if I keep moving the mouse when it's lagging, it'll never go away. I need to stop moving the mouse for 2 seconds or so for it to fix itself. Then of course it happens again after I click on another tool or window.

 

No unusual CPU activity when this happens. Nothing else running on my system when it happens. It only happens with CC applications and it happens with every one of them. 

 

  • CC 2018 and 2019 ran fine before I reinstalled Windows 10 on to a clean SSD so it's something new.
  • If I use the keyboard shortcut for a tool - it does not do it! But this is not a fix because you have to regularly click on windows in the application, and that causes it.
  • If I switch physical mice (wired or wireless), it still does it, so it's not tied into the mouse hardware.

 

My desktop:

  • i7 / 6700 / 32gb
  • 1080ti Graphics Card, gsync monitor at 144hz
  • All SSDs
  • Nothing overclocked
  • All latest drivers and updates for every system component.
  • System runs like a solid speed demon in every other application and game other than CC

 

Any help would be appreciated. I'm at my wits end and can't use the products because of this.

TOPICS
Bug, Performance, Problem or error, Windows

Views

613

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

The solution was to disable G-Sync for WINDOWED applications in the nVidia Control Panel. Keeping Gsync enabled for Full Screen only fixed the problem.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Just ran into this issue on my new machine and it was driving me nuts.

Setting G-SYNC to be enabled for full screen mode only seems to have fixed it.

Thank you!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines